Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Can't receive calls or text on galaxy watch 4 esim

(Topic created on: 25-08-2022 06:38 AM)
sskelA
Journeyman
Options
Wearables

Have  galaxy watch 4 with e sim number. When connected to phone I don't receive any calls or messages on that number, but when I Disconnect watch from phone I can Receive messages and calls on e sim number.

What settings I have to disable or enable to receive calls and messages on galaxy watch 4  esim number without disconnecting it from phone.

 

Edit: https://www.reddit.com/r/GalaxyWatch/comments/tdoj92/when_sending_a_text_from_my_galaxy_watch_4_i_am...

From this I understand that when connected to smartphone watch by default is using only phone number. Lets give option for e sim on watch, but lets remove option to actually use it. How can those developers be so so fuc....ly "smart"

 

Edit:

Got it at the end working by -

-Settings - Connections - Mobile Networks turning to alway on

-Opened phone app on the watch. Scrolled down to Settings at the bottom. Taped it, then taped 'Preferred number' selected  watch.

2 REPLIES 2
Neo001
Big Cheese
Options
Wearables

Hi,

 

Disclaimer: I have a watch 4 with BT, so not an esim one. 

Have you tried to enable remote calling in the settings in the Wear app?

 

Wear app on your phone --> Watch Settings--> Advance features --> Remote connection --> Calling --> toggle the switch on.

Hope this helps.

Solution
sskelA
Journeyman
Options
Wearables

My main goal was to receive, make calls and receive, send messages from watch e-sim without using phone. Remote calling wouldn't cut it as main goal is to use e-sim.

Got it at the end working by -

-Settings - Connections - Mobile Networks turning to alway on

-Opened phone app on the watch. Scrolled down to Settings at the bottom. Taped it, then taped 'Preferred number' selected  watch.