Open search

Can't connect Galaxy Fit-e to iPhone 5s

First Poster

iPhone 5s 1gb ram, Galaxy fit e bend , iOS app  Galaxy Fit.

The bend is connected to the iPhone, but the app can't find it.

Please help

@Nepal: Is your iPhone 5s on iOS 9? As a troubleshooting step please remove any Bluetooth connections you have established with the Fit E, then open the Galaxy Fit app, hit 'OK' when it says 'Galaxy Fit would like to use Bluetooth' and follow the on screen instructions to complete the connection.


Remove it from the iphone's Bluetooth list and reset the Fit e. Then try establishing connection through the Galaxy Fit app. You can also check out this video; (Galaxy Wearable: Connecting Fit 2 Pro with iPhone).  The process is similar. 


Hi , I'm running iOS 12.4.2 on my iphone 5s. The phone will find my new Galaxy Fit e, displaying D6C3 as shown on the Galaxy Fit e. But, when I tap connect, it just says 'connecting to band' and then eventually times out. It won't get past this point. 

You mentioned resetting the device. How do I do that if I haven't been able to get it going in the first place?




I had the exact same issue on my 8 plus running on iOS 13.3. I just bought a fit e and tried to pair it right out of the box and nothing seemed to work. 
What I did and worked is I took an android phone, because I wanted to see if it worked or not. It connected on the android phone and it seemed that there was a software update for the band. I did the update and disconnected the removed the device from the android phone.

After that I just opened the galaxy fit app on my iPhone and it connected right away with no issue.

Top Liked Authors