Open search

Can not install samsung health update.


After Samsung Galaxy Watch 42mm with One UI update,  I can't install Samsung health update on the watch. Watch just disconnects when update is installing. I have Samsung Galaxy S9 (One UI)  &   Samsung Galaxy Watch 42mm (One UI).


second method works, thanks :smiling-face:

@tlexul  but is it still trying to update itself on the phone? I'm not 100% sure if the version is really the same if it's not trying to update it. 

@GreatAnubis wrote:

@tlexul  but is it still trying to update itself on the phone? I'm not 100% sure if the version is really the same if it's not trying to update it. 



And before I reconnected the watch to the phone (following option 2), I force-closed samsung health on the phone to make sure it doesn't interfere.


Later edit:

Well, it worked. I disabled the Reactivation Lock (in the Galaxy Wearable app, under Find My Watch, under Get security) and reset the watch again. Now I got the latest version installed and in the Galaxy Store I have no updates pending.

Thank you resetting the watch and updating the app from the watch worked for me

The Samsung Health App never shows up in the My Apps list on the watch. I did hard reset many times. This app never shows up on the list. All other apps are there.

Instead of cheating around with multiple resets, I prefer to get an official fix from Samsung. Only this will ensure proper behavior. Everything else is just a temporary work around until the next app gets stuck due to the same bug.


Obviously that's a workaround. However, seeing no feedback from Samsung so far I wouldn't expect they will patch that soon :winking-face: So for now I'm happy with it as I can use my watch again having all feature set available.

Are you not able to use your watch without the Samsung Health update? Mine works fine. It shows that there is an available update, but this doesn't hamper the performance. And who knows what's in this new update :), maybe more bugs.

One thing I have noticed. The audio files and gallery photos that I have uploaded to my watch are not a part of the backup and restore prodecure. Also, the navigation maps that I download are all gone - pretty much you have to start over with setting up your watch from scratch, which is extremly time consuming.

As a user of open source projects, I tend to install only older stable versions, while leaving the experimental ones to the enthusiasts who have time to debug them - I am eternally thankful to them for that!


you're talking to software dev with 19y of experience :smiling-face: I'm that guy living on the edge of stability of experimental stuff :face-with-tears-of-joy: That's why I'm always sharing my findings with others :smiling-face: Just willing to help mate.

anyways, I've had to install some older version of SH on my mobile because it's broken for me. I can't select my watch as a source of steps (see my other thread in this forum).


Same issue here: S10+ and Watch 46.

Tried reset, reboot, factory reset and service menu recovery.


After first failed attempt sensors stopped working - wake up sensor, heart rate, floors, steps, barometer.

Barometer app cannot load now even after manual calibration.

So the watch is not usable because let's be honest - notifications and measuring time is small feature of this watch. It's all about training.


Read the reviews under Samsung Health watch app in galaxy store. People are asking to fix this from weeks. Samsung WTF, where R U?


EDIT: I also tried @GreatAnubis method. No effect. Preinstalled apps are not visible on My Apps list in Galaxy Watch, just in Galaxy Weareable phone app.

Same problem.cannot update Health on my watch tried dozens of times 

Top Liked Authors