Open search

Yet another smart hub died. Come on Samsung!


Same problem that thousands of others seem to be having: software updated to version 2127, and now the smart features don't work. The TV is now an expensive brick.


"Smart hub is being updated. Please try again later."


Tried the soft reset, hard reset, factory reset, the "wait five minutes" trick, the launching apps from the features menu. Nothing works. The latest software update has killed the TV.


Model number is UE22F5400, for what it's worth. Network connection is fine. 


Interestingly, when I look in the smart features menu, the "Samsung Account" option is now greyed out - selecting it brings up the message "This function isn't available". This has to be related to the problem? Why will my TV no longer connect to my Samsung account?


There are so many people affected by this. Even if you don't have a fix yet, could you at least let us know that someone is working on it? Or do we need to return our TVs and not risk getting another Samsung TV if this is what happens to them? 

First Poster
Gutted. Mine is exactly the same and I was searching for the answer and come across this! Are we buggered then?

I'm hoping Samsung come up with a fix. Surely they can just roll back the broken software update if needs be?


Bricking everyone's TV isn't the best move. 

New Member

I had exactly the same issue!


I rang their support number and provided remote access pin and they sorted everything out remotely!


it all works again!!!!


it took about half an hour for them to answer but it worked


just give them a call guys!




Hey @JamesPSams and @Darrien1992.


We can see you also responded in this thread. So we can assume you've already tried the troubleshooting @AntS provided. As this hasn't worked we would urge you to get in touch with our TV Support Team as @Olowyol did and ask them to help out with this. 


You can contact them on 0333 000 0333. 

 Welcome to the Community! :smileyhappy:


Can you please post the fix online as, understandably, the call centre is currently closed - but could do with iPlayer at the moment. Thanks 

First Poster

I had this problem and tried many suggested fixes without success.
My tv was connected via a wired network. I disconnected the ethernet and connected via wi-fi. I was immediately able to download all apps that I wanted. I went back to wired network and problem has disappeared.

TV is 2015 model UA48J6200.


Thanks, unfortunately didn't work for me.


@MarkyMark74 wrote:

Thanks, unfortunately didn't work for me.

I forgot to add that I set my phone up as a hotspot and connected to that.
Might be worth a go.


Returned Samsung tv on version 2127

 Now lost all channels. Can you advise what to do next please

 Prior to autotune had several error messages about the smarthub

Top Liked Authors