What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

[UPDATED firmware v1251.0] QLED (2018 models) real world experience (firmware v1202.3)

(Topic created on: 03-05-2019 08:33 AM)



I want to report a couple of bugs that are unacceptable for a "smart tv", especially the QLED *premium* model ones.


First of all, smart hub is utterly unusable and sporaddic!

As a CENTRAL menu that operates almost EVERYTHING we users use day-to-day in the TV, it HAS TO work 100% of the times, with NO exceptions.


Smart Hub bugs:

Not showing up at all when starting up the TV (as a rule this can be reproduced without a problem when starting from sleep mode):

    - The only button that reacts is the useless ambient mode, which I guess is a seperate feature / service so, it has no problems starting up...

    - The only option we than have is to use a soft shutdown (click the power button), force restart (hold the power button until the TV boots normally with the QLED logo), and the third option, which should not even be an option, hard shutdown (pull the power cord). Here even the shutdown "animation" does not show when using a soft shutdown (sleep mode)


Finally showing up after the N-th time of turning off and on the TV:

    - When it does show up, and we try to open an app (i.e. Youtube, Netflix, Plex, ... ALL essential apps for a TV that advertises itself as smart) it is uncapable of connecting to the network. Am I supposed to watch content in offline mode in these apps? :face-with-tears-of-joy:

    - Again we need to: exit the application (either normaly, or forcefully by holding the back button), and reenter the application for it to work.


It seams nothing on this TV works from the first try...


And these faults are just an appetizer, to see if anyone will even respond and acknowledge the feedback from the people WHO ACTUALLY BOUGHT this ***** thing.


I know it's becoming a trend in big corporations to use the end users as Quality Assurance testers, but at least listen to them then... It CANNOT BE POSSIBLE that noone at Samsung did not detect these issues. A quick google search will tell you I'm not the only one having these issues.


Solutions :face-with-tears-of-joy: / workarounds such as:

- Reset Smart Hub

- Enter manual IP and DNS addresses

- Similar nonsense, not my job hints

are not VALID, should not and will not be considered.


By the way firmware version 1153 has the same faults as v1202.3, and not only that, but the newer, more *stable* and *improved* 1202.3 does these faults more often :face-with-tears-of-joy:


If I had to propse a solution for a hotfix:

- Let us configure to disable the "fast boot" setting that appears to cause most of these issues

    - In other words, stop making your TV act faster than it really is by caching states of applications at an expense of not having them work at all. In the end, for users that face the same issues as me, this behavior takes up more time than booting up normally anyway, as we have to do everything at least twice.

- Let users access and share the TV logs so that we could actually help with more specific information and errors generated by the TV


Still enjoying the "features" on a daily basis. IGN 12/10 would buy again, lol.




You will get nothing out of Samsung, they don't really support their TVs in any meaningful way, and wonder why their sales are dropping year on year.


If you can I would return it and buy something else.  


We still have bad judders and white frame flickers on our 2017 model that has had loads of firmware updates, all of which come with no release notes so you have no idea what they address.  Usually it seems the update just enables another way of showing some advert in the menu system, as that is the only difference we have ever noticed.








I agree. Since I have posted this thread, I have been monitoring the forum, and I see zero intrest from any officials. The sad part is that other major manufacturers arent any better in comparison. Well, lession learned.


My preliminary tests of the latest firmware v1251.0, seems to show somewhat positive initial results.


The connection problems on wake from sleep, no longer persist throught the first session.

For instance PLEX app used to show connection error dialog, that would not go away until app or TV reboot. This is no longer the case. When waking the TV from sleep and immediately entering the PLEX app, the first second or two show the same dialog (since the TV has not had the chance to connect in that instant), but it than refreshes the state and manages to connect. That would have been an expected result from the start. So thats a :thumbs-up-sign-emoji-modifier-fitzpatrick-type:


I will update the thread once I have time for more thorough testing of my initial post / complaint.

First Poster

Yes my Samsung TV has decided not to stream any more after about 5 years without any issues. My fibre broadband is  showing good latency 14-18ms and download speeds of 36mb - tablets, laptops and phones are all fine and even the other cheaper smart TV  works but this bloody Samsung TV will not stream anything longer than a few minutes if that.


A few nights ago it did stream one Netflix movie without a glitch, first time in about 4 weeks! But it's reverted back to it's old ways, the next day. No streaming...


As you say, nothing works! It's very frustrating.


Power reboot...I held that red button down for ages and nothing. I've deleted apps, reset the TV, reinstallled apps, logged out, logged in (Netflix) but I get the same thing. Network error, not connected....


Network settings begins, gets to the part where you select your router and it then flashes past it really quickly in the blink of an eye and exits the entire network set up mode. I briefly see my router details there as it flashes past it but there's no way to edit it, remove it,  change it or re-add it.


I've also split the router so I'm using both 2ghz and 5ghz. Maybe I need to revisit this again as I'm out of options now.


The TV says I'm connected in network mode but then when I try to watch BBC iplayer or Netflix it says network error - you are not connected to the wifi. It's driving me insane and there does not seem to be a basic fix for this.


I even tried the 'use your phone as a hot spot' method, which possibly worked as I did manage to re-add my original router back, perhaps this is why it let me watch a film all the way through the next night.... but I'm back to square one now.


Surely I don't have to buy a new smart TV? Or I guess I'm watching all films on my laptop from here on in....


First Poster

Last software update (OTA) messed my tv up. First all the colours went mad, tv wouldn't boot. Sometimes takes 4-5 minutes to boot. Led flashing etc... And I can't access the Apps menu or open any preinstalled apps. QE55Q6FN







is there anyway to RE-install the firmware?? I have issues too because it was forced OTA just in the moment I was using the pendrive when updating... all went bad with wifi 


 For situations like that, your best bet would be to go to an authorized service technitian and claim your warranty. We consumers have only two options for firmware updates, USBs and OTA. Since your devices are FUBAR, you as a consumer dont really have access nor equipement to repair such device states. Technitians usually have a dedicated service port / interface, where they are allowed to forcefully reflash the firmware and try to repair that way.


As far as the O.P. post goes, the situation is a little better. For me at least the connection is now at least useable. Still not flawless but O.K. enough to tolerate its minor faults described in my posts above.


The next things on the list would be the subtitle picture washout on HDR content (well known and documented issue).

I've also noticed that when you wake the TV from sleep, it does not properly register HDMI black level for devices that use full spectrum 0-255 RGB levels. Again on first wake from sleep it reads the EDID's HDMI RGB range as limited, and than on later wakes it corrects itself and displays the full range picture. Again this did not happen on previous TVs connected to the same source.