What are you looking for?

Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

UE46C7000WW Internet@TV not working

(Topic created on: 14-11-2020 08:29 AM)



I own an (old) UE46C7000WW. It has a Internet@TV feature which used to work. 


Recently, I successfully updated to the latest firmware (T-VALDEUC-3018.1). Also, I had the Internet@TV settings reset manually (by launching Internet@TV Settings > System setup > Reset).


The Internet@TV feature has stopped working since then. When it starts it shows a sort of welcome message but that's it. Pressing the ENTER button shows a Samsung splash screen which you can only RETURN from. No other option or button is available. No Samsung Apps, no Settings. No apps are loading. It's like of it is stuck there and after a while it exits to TV.


I am pretty sure the Internet connection is correctly setup. I use a wire to connect the TV directly to the router. All tests pass.


Any ideas on how to fix that problem?


Thank you in advance,


@Andrex655  Do you really believe @maxximum has the solution? 

Of course not. This is classic troll behavior. @maxximum should be banned.


I found a solution:

1. turn off, turn on tv.

2. press the Internet button more times quickly for 5-7 seconds (3-4 entries to the Internet@TV menu).

3. stop when you are in the internet tv menu. Done!

But the main problem is that there is no longer YouTube, netflix and most programs do not work. Only vudu and plex works

First Poster

AWESOME! Been kicking my butt for awhile, but this worked! Be safe and thank you!


It worked the first time but then it got stuck again. But yes, no YouTube, no Netflix. Have to replace the model.


Does not work for LEC650. 😞

First Poster

Let me give ya'll what you're truly asking for... this was literally discovered after extensive searching for weeks on this topic.  SUPPOSEDLY Samsung INTENDED to remove the Internet@TV functionality from all the older smart tvs because they dont support it anymore.  It is in the same generation as the "Yahoo" Vizio older smart tv's.  The new OS isn't compatible... but here's the proof if anyone wants to enable the functionality again in their tv, (Let me warn you, USA, CANADA, MEXICO and many other countries will not have local content accessible because they phased it out in these 3 localities 1st, but you can still use it via the method described below) 

ANY FW will work!  

1. On your tv, first go thru to your menu, and select the {gear} which will have the "NETWORK" setup menu. 

2. Click on "Network Test" and make sure you get all check marks (everything is good). IF ANYTHING FAILS HERE, FIRST GET YOUR NETWORK CONNECTION WORKING!

3. Exit out and press your {Internet} button or whatever you use to get to the 1st internet@tv screen, where you get the "Connect to the internet..." message

4. Wait about 15 sec here, then aim your remote at the screen and press the following combination.  (Doesnt have to be fast... just has to be uninterrupted.)

>> , 2 , 8 , 9 , << 

(Thats the "FastForward" key,  2  8  9  ,  "Rewind" Key)

this will ONLY WORK if you are connected to an active internet connection.  

\\\ this sequence will connect your device to the internal REGION selector of your C-series TV. I dont know about others (I heard it works on D as well) ///

The region's I have tested that work in English were United Kingdom, and Australia, but Puerto Rico, several Indian Language regions, Russia, and a few others work. USA will just take you back to not working.  If you want the function still active just choose "United Kingdom" .. the screen will close and an icon that says "Dummy" will appear in the top screen apps selector.   Click "enter" on your remote and it will say "Internet@TV needs to update, Downloading updates". in a few (45) seconds your service will be working again, albeit very limited functionality since the apps store has a very small selection.  Theres no Netflix, hulu, or many others, but im working on figuring that out.  The best decision is to find and follow one of the Firmware downgrade guides and go back several versions to one that you knew worked, then on your router BLOCK THE SAMSUNG UPDATE IP's.  Hope that helps...