Open search

TV suddenly started showing sports in Spanish


My TV running software version 1231 suddenly started switching the baseball and football games to the Spanish language.  Most of the time shows like Sunday Night Football and the local baseball games are in Spanish, but occasionally when I turn the TV on without changing channels or any settings, the game is in English.  But, most of the time they are in Spanish. 


Other TV sets connected to the same cable system are all in English all of the time, so it isn't the cable.  It is the TV.  I checked the setup and the chosen language is English.


Since football season is just starting I would like to solve this problem.  Any ideas?







Hi @DrSylvia , :smiling-face:


How odd! I've done some reading around for something similar on the internet, and it sounds like it might be an SAP (Secondary Audio Programming)/MTS issue.


What's the model number of your TV?

Yes, it is very odd.  I have been struggling to find out how to get back to 100% English.  What is really odd is that sometimes the same channel showing the same sport is in Spanish and sometimes in English.  There must be a clue in there somewhere, but I haven't been able to find it.


My TV model (if I read the numbers correctly, hard to see the back of a big TV), is UN4OKU629OF.


Any help is appreciated.




@DrSylvia , 


Broadcast SAP/MTS isn't a UK thing (as far as I'm aware), but as far as I understand it also depends on how the broadcaster's embedded MTS/SAP signal is at any given time - which may explain the language switching.


Guessed it might be a US TV! It's a little even more out of my knowledge zone than Audio/Visual stuff would be (lol), but it's this model: 


If SAP/MTS is indeed the culprit here, then the User Manual for points towards adjusting advanced Broadcasting settings:


UNKU6290F_ Broadcast Audio Options.JPG


(MTS/SAP looks to be 'Multi-Track Sound' in there, but you may need to check that the 'Preferred Language' is set as you want it too.)


Check those settings out, and let us know how it goes, Sylvia. :smiling-face:

Thank you, again for your help.  I find my TV menus are quite different from those you showed in your post.  I have a manual that is accessible from the TV without using the Internet.  I didn't find anything useful in it checking it before I posted here.


I can't really tell whether the small changes I made fixed things until there is a sports broadcast that usually defaults to Spanish.  Tonight after our local dinner time (7:00 PM CT in the US), I will be able to check Thursday Night Football, and one of the Baseball Playoff games.  Those often come in Spanish.


There are two places to check the preferred language in the program.  Both are and were set to English.


This afternoon I went through the menus and there are not a lot of choices for some of the settings.  One setting that I changed was under Broadcasting/Expert Settings/  I changed Channel Bound Apps to OFF from ON. 


I also changed System/Expert Settings/Autorun Smart Hub to OFF.  I think I tried that before and it didn't help, but I thought to try it again.  It is easy to reverse these changes if they don't help and may be needed.


I will report back when the sports come back on our cable system after dinner tonight.


Sylvia (in Minnesota, USA)



Well, I found the two sports channels on my TV didn't change when I made the small changes in the program that I mentioned in my previous post.


NFLHD Thursday Night Football was still in Spanish.  The MLB baseball playoff game was in English, but that is probably because it isn't a regular season game on our regular channel. 


What I did do to check the changes, was to go to a cold start.  I unplugged the TV and cable box and restarted them.  Then, I checked the channels with the result I mentioned above. 


I am thinking that I will unplug and restart the cable and TV and go to the startup menu and dump the entire program and reset everything.  I don't know whether I can get in trouble doing that, but I doubt it.  It is about the only thing I haven't tried.  Any thoughts on trying that?


Friday night is not a night with a regularly scheduled national football game that I know would have the trouble.  Sunday Night Football and Monday Night Football would definitely be games that I watch and can check.  I will check sports over the weekend, but I haven't noticed other channels going to Spanish audio.


I hope I am not taking up too much of your time with this.  If we can solve this, we may help others.  I can't be the only English speaking person who doesn't like watching sports in Spanish!






I'd be tempted to do a reset of it all at this stage too. :thinking-face:


However, it might also be worth getting in touch with Samsung US Support for some expert guidance: on both the TV and MTS/SAP.


And it's all good, Sylvia. :heavy-black-heart: :smiling-face-with-sunglasses: I kinda enjoy the odd ones that make me think ... and even I don't solve them, I want to know how they turn out! :winking-face:

Hello, again,

I am sorry I didn't post sooner.  My husband had a rather severe problem over the weekend and we spent Saturday night in the hospital Emergency Room after a midnight ambulance ride, sirens wailing,  through mixed snow and sleet to the big hospital in the city and we spent Sunday in the main hospital.  Luckily, my husband is OK and was able to come home.

I wasn't able to watch sports over the weekend, so I didn't work the Spanish problem.  Last night, Monday Night Football was on ESPN here and it was in English.


I still plan to reporgram everything on that TV, but the next two days are filled with appointments for my husband.  I will get back to you and report what happens when I reprogram.






@DrSylvia , No worries at all, Sylvia. And wow - that sounds like a weekend from hell. 😞 I hope your husband gets well soon.  :heavy-black-heart::four-leaf-clover:

So sorry to hear that @DrSylvia  hopefully your husband will recover well.  :heavy-black-heart:Just test the Sports language issue when you get  free moment.

Top Liked Authors