What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

TV QE55Q68A recognize my motherboard but not my graphic card in HDMI

(Topic created on: 03-01-2022 07:35 PM)
First Poster


English is not my native langage, so I will try to be as clear as possible.
I have a GTX 970 4G from Gainward
I bought a new TV 4K, a SAMSUNG Q55QE68A. Just to plug my PC and play from my sofa. I can plug it in my motherboard with GPU integrated, it works. The TV recognize it as a PC and displays windows. But I have a graphic card, I want to use it. Plus the GPU integrated is terrible.

The graphic card works fine with an old screen plugged with DVI → VGA
And it worked before with a Hisense TVHD 4K in HDMI

I tested with a mHDMI → HDMI cable, and with a classic HDMI cable + adaptator mHDMI. It doesn't work.

The TV sees that a device is plugged but shows a message : "check the device power" or something like that in french.
However, NVIDIA config panel finds easily the TV, the device is a HDTV - SAMSUNG, the GPU finds its native resolution and I tested to modifiate the refresh rate to 30. 

I tried to unistall the GPU, its drivers, the TV drivers... I didn't work, even in 1080p.
I don't know what to test now, I bought for 150€ of cables and adaptator, I'm about to give up.

I called the Samsung support but wow it sucks, they clairely are not capable to help me. 😞

If you want more information, don't hesitate to ask.
Thank you in advance.


Hi @DyingPotato. Head into Source > HDMI > above Source there is an upward arrow and you can choose what the port is for through Edit. You may see the option for PC here. Failing that, it may be something to do with the refresh rate. 

First Poster

Hi, I have already try that. But the Tv still tells me that the device is shut down. 😕 You're not the first to tell me that it can be about the refresh rate, but I tried with 30Hz, with different resolution and I can't see difference.

My graphic card cannot handle 4K@60Hz, but my sh***y  GPU intergrated neither, and this one works though!