Support

Open search

TV keeps disconnecting from WiFi

Highlighted
New Member

Hi, my Samsung smart TV (UE49NU8000 49, purchased 11 months ago brand new) keeps disconnecting from my WiFi. I have spoke to Samsung and they have even gone to the measure of sending a third party company out to replace the part that connects to wireless networks. However, its still doing it. 

 

The only way I can get it to reconnect is by turning the TV off and on again, it will not reconnect if I try and do it through the network settings, I have to turn the TV off and on again. 

 

I have spoken to my Internet provider, and all is fine on their side, and no other wirless connection (phones, Xbox etc) ever disconnect. 

 

I have done multiple factory resets, most of which were done whilst on the phone with Samsung, and all updates are done too. 

 

I am at a total loss, can anyone help? 

Thanks. 

 

 

 

122 REPLIES 122
Highlighted
New Member

Same issue here.  Just got an 85" Samsung TV Model UN85TU8000FX2A  a week ago and it buffers and disconnects constantly.  Network Error states "TV is connected to WiFi but Not connected to internet" while there are no other iternet issues with other devices in the house.   I had zero issues with the LG TV that it is replacing (in the exact same location), or any other devices in my house while this happens.   I'm going to try some trouble shooting based on some of the comments here but   I sure wish I would have seen this post before buying this TV.    I'm also going to post this link to other review sites because this seems to be a problem across the board for Samsung TV's and has been for some time.   Either related to the WiFi hardware or a software glitch, which it could be the latter based on some folks saying that it started on their TV recently, which may indicate a software update.   So far a soft reset (turning the TV off for a minute then on again) has established the connection again, but it reverts to Samsung TV and not what you were watching.  We have to go in and restart the app we were watching and relaunch our program.  Over the Moon annoying.  When I contact Samsung customer service again I'll be referencing this link with 11 pages of common complaints.  

Highlighted
Observer

I’m another one here with the same problem with my 40NU7120 and 

QE43Q60R TVs, so it is a consistent fault among Samsung products. It’s often daily now that the 40” TV has internet issues. When I try reconnect to the internet no router shows up, not mine or even any of the neighbours’. I have to power it off via the mains and then it’ll reconnect to my WiFi instantly and if I search for a WiFi connection, my neighbours WiFi router also appears; this further implementing this is a Samsung issue.
Like others I can also confirm that this problem gets worse over time, as it became more frequent with the 40” and it’s starting to happen with the 43”. Samsung support is absolutely useless. I’m going to try get a refund on the 43” as I only got it at Christmas, but for the 40” I’m thinking about getting a TP link so I can connect via Ethernet. Has anyone had any luck with an Ethernet connection or does the problem still exist? 

 

Highlighted
New Member

Exactly the same is happening to me except I'm at the point where the next step is to replace the WiFi connector. I might just take it back to the shop, Samsung aren't really solving the problem. 

Highlighted
First Poster

We'd been having this hideous problem for many months and were accustomed to rebooting the TV and resetting the internet connection  literally 5 times in one show.  My husband finally solved this for us,  and we are living happily ever after in Samsung heaven.  He noticed that whenever he unplugged the TV, the remote would start flashing. Eventually, he somehow got a hunch that the remote was communicating bad juju to the TV.  So he tried hiding the remote under a sofa cushion once the TV was reconnected and working, and the TV did not lose connection for an entire night.  This was nearly 2 weeks ago, and we have continued to "hide the remote" every day and have perfect results every single time.  It sounds pretty crazy, I know.  Please, somebody else try it and let me know if it works for you too.  

 

Highlighted
First Poster

We'd been having this hideous problem for many months and were accustomed to rebooting the TV and resetting the internet connection  literally 5 times in one show.  My husband finally solved this for us,  and we are living happily ever after in Samsung heaven.  He noticed that whenever he unplugged the TV, the remote would start flashing. Eventually, he somehow got a hunch that the remote was communicating bad juju to the TV.  So he tried hiding the remote under a sofa cushion once the TV was reconnected and working, and the TV did not lose connection for an entire night.  This was nearly 2 weeks ago, and we have continued to "hide the remote" every day and have perfect results every single time.  It sounds pretty crazy, I know.  Please, somebody else try it and let me know if it works for you too.  

Highlighted
First Poster

Same happens with my Q60T - global model. It's not so frequent, but happens. I will try to disable ipv6 on my router, because there's no such option on my expert settings. If it doesn't work, i will "hide" my remoter and see what happens.

 

And someone can answer me: Ethernet Cable have problems or is just wifi?

Highlighted
Observer

I own a Samsung Q90R which is wired to the internet and was experiencing "Ethernet disconnected" and then "Ethernet reconnected" issues frequently. Running the SmartHub network test from the "Support" -> "Self-diagnose" would complete 4 out of 5 steps without any indication as to why.

 

What seemed to solve the disconnect/reconnect problem:

After trying many things, including factory resetting my TV, I speculated that it may be a port-forwarding issue with my router.

I went to check my router-setup and tried disabling uPnP, which makes it impossible for the TV to ad-hoc open incoming ports (for whatever reason).

The Smarthub test can now complete and I am on day 3 without "ethernet disconnect" errors. I would usually see the error 3-10 times a day.

This notification may just be prompted because the TV is somehow trying to use uPnP in some strange manner.

 

Try disabling uPnP on your routers and report back with your experiences :smiling-face: Hopefully this will help someone as annoyed about the notifications as I was. :smiling-face:

Highlighted
New Member

Lesson = Don't buy a Samsung

 

These are not cheap TVs and I feel ripped off. Can't do basic "Smart TV" things consistently

 

My next TV will NOT be Samsung. I wish I'd read this before buying

Highlighted

and iplayer in UK

Highlighted
New Member

We are having the same issue with a Samsung TV we bought two months ago.  I have to completely unplug it for the internet to reconnect.  It seems to be happening every other day or at least a few times per week.  Has anyone heard from Samsung regarding this issue yet?

Top Liked Authors