What are you looking for?

Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

The Frame (2021), Xbox Series X and Firmware 1506

(Topic created on: 26-05-2021 12:36 AM)

Hi everyone!

We got 2x The Frame 65" 2021 and 2x Xbox Series X.

Two days ago one frame suddenly stopped working with the HDMI "Game Port".

The day after the other one experienced the same and now none of the TV's HDMI "Game Port" works with the Xbox. TV's just displays a "check input power source" message.

Connecting the XBOX to another HDMI-port works fine.

I checked the latest firmware @ Samsung support page and it says 1506 was made available last week, so my hypothesis is that it breaks "HDMI Game-port" functionality when using the xbox series x 4k/120hz.

I've played around with disabling VRR, HDR etc. on the xbox to no avail. Also had Samsung support remove into the TVs and first reset EDID(?) and then full factory reset.

Didn't fix the issue.

Currently using another HDMI for the Xbox but would prefer to get it back into the GAME-port as this supposedly provides a better picture and VRR-support etc.

Anyone got ideas? :smiling-face: 



1 Solution

Accepted Solutions

OP here.

I can confirm that the micom 1227 update was successful in restoring the combined 4k/120hz/VRR/HDR-functionality in my Frames (65", 2021).

Requirements to complete procedure:

- The update-file ( located here.

- An old Samsung remote control with the following buttons:

  INFO, Menu, Mute, Power*

- An USB-stick formatted to exFAT (FAT32 might also work)



- Download the update-file (linked above) to a computer and unzip it (filename should be NM2MICOM_FRJP.bin)

- Copy the file to USB-stick (root directory, do not put it in a folder)

- Insert the USB-stick to the Samsung Frame one-connect box (USB-connection should be on the right hand side)

- Ensure the TV is in standby-mode (showing artwork)

- On the old remote press the buttons in the following order:



- The TV should turn on and display the service menu. 

Note: If it does not, put the tv into standby mode again and try again, or try one of the different button combinations as described in the footnote.

- Navigate to SVC -> UPGRADE -> Submicom JP USB UPGRADE.

Note: Use the "right arrow" on the remote to navigate to the next sub-menu.

- Hit the "OK" button on the remote (in the center of the navigation-arrows) to apply the upgrade.


The TV should spend around 10 seconds to apply the upgrade, then it will reboot (screen will go completely black) and when it turns on the 4k/120hz/VRR/HDR issue should be solved and you can connect the Xbox Series X (or PS5) to the GAME-HDMI-input :smiling-face:


Note: Playing around with the service menu could in theory damage your TV. Use procedure at your own risk!


* There are multiple versions of TV-remotes which require different button combinations to enter the service menu. A list of different remotes/button combinations is available here.

View solution in context

403 REPLIES 403
strawberry cake




try lowering your refresh rate

then change the resolution

and check the Source Menu on your remote



(")_(") strawberry cake so delicious


Hi and thanks for the reply.

I played around with the settings a bit and found the following:

* The TV accepts a 4K UHD/120hz signal via the ordinary HDMI ports.

* The TV does not accept a 4K (60 or 120hZ) signal via the GAME HDMI port.

Without using the HDMI GAME port I lose functionality like ALLM/VRR (and possibly 120hz?), so I would very much like to figure out what's wrong and fix it :smiling-face: Any ideas how to go about that (except from involving Samsung support which I will later today)?


Hi !
I have pretty same issue with The Frame 2021 and XSX after firmware upgrade. I've tried different settings on HDMI 4 as workaround, but without luck. On other HDMI ports there is no problem at all. I think we need to raise support request from Samsung.


Hi there!

I spent almost a hour today on the phone with Samsung support, and they finally escalated the issue.

They remote connected to my TV and repeated all the troubleshooting-stuff I already did and observed the issue for themselves.

They agreed that they suspected that its a software issue, and they have sent an internal request to the "TV-specialist department" to look at the case. They told me to expect an reply within a week-ish.

I'll report back here with more info as it becomes available to me :smiling-face: 

Samsung Members Star ★★

Hi @BrontoTaurus A pity you were not able to achieve the best experience  of ALLM/VRR.   However glad it was escalated  and hopefully a solution can be found.

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


Hi, I have the exact same setup as you- 65 inch 2021 The Frame and Xbox series X.

just got the Xbox today and was tearing my hair out wondering why hdmi 4 would not work. I am also on firmware version 1506.


Have you had any update from Samsung since your post? I’m guessing that we will just have to wait until a firmware update



Sorry to hear that your are also experiencing this problem 😞

I have not heard back yet and will give them a call later this week if they still haven’t gotten back to me.

Will keep you posted!

take care,



I recently bought Xbox Serie x and I'm having exact same issue as described in this post with my 2021 Frame tv (65inch).  Clearly there's bug with software by the fact all reporting the exact same symptom. Can we have an update on this? 


Same Frame 65 same Xbox series x, same problem… the support don’t help me. I wish the update don’t arrived too late