Open search

Smart TV continually restarting


Hopefully someone can help/advise on the problem I've got with my Smart TV (UE40D5520RKXXU).


A few days ago the remote was used to power the TV up but it wouldn't get passed the start-up screen switching itself off then trying to restart reaching the same point and shutting down and restarting again, this just goes on and on.


Now the power is switched off as it won't start but when the power is switched on it automatically tries to start but fails every time as above.


The TV is about 6 years old, in perfect condition, I'd like to keep it but only if it's going to cost a reasonable amount to sort out.


Last year this same thing happend and I opened the back up to have a look around to see if anything obvious was wrong and with a many power on/offs it started up, much to my surprise, so the back was re-attached and we had been using it without any problems for the last 8 months.


Could the problem be in the software or is it a power supply problem? Hopefully someone can come up with a suggestion or two.


Thanks in advance.



Accepted Solutions

In this instance we wouldn't be able to resolve the issue through troubleshooting.


If your TV's out of warranty, we'd recommend contacting your nearest Service Centre. If it's still in warranty, please contact our Support Team for assistance. 

View solution in original post


Hi @Jimm,


Have you checked to see if there are any updates available for your TV?


Menu > Support > Software Update


You can also check your software version here: Menu > Support > Contact Samsung.


Check out this LINK for downloadable software and this LINK for installing the software. 





Say "hello!" and
Introduce Yourself, or virtually hangout in the Samsung Lounge


Hi TracyR


Thanks for your reply and advice, I was due to update the forum on my post.


The TV, after a week or more of testing with power on/off etc came up with a screen of 'no input source', i.e. it finally started up and only needed an aerial or other input to work. This is what happend last year where it eventually started up also after quite a while of power on/off testing and periods of no power to the TV.

I wonder whether there is a software issue though the firmware is up-to-date. I have turned off the auto power off setting in case that may be part of the problem.


Anyway, at the moment, with fingers crossed it's working normally, 


Thanks again.


Regards Jim


Just to add for you and anyone else who read the OP, I wasn't able to control the TV at all when it was trying to start, I only saw the Smart TV splash screen for a brief moment before it shut itself down to try again to start, this was continually repeated. I've read on the internet something similar and was termed 'boot loop'.

For some reason, in my case, twice the TV has come out of this 'boot loop' and managed start successfully.

New Member

I have a Model UN55D6420UF from the 2007 time frame which has the same problem.  After searching the internet, there are people with the same issue going back to the 90s.  I paid a service tech $500 to replace the board that was causing the problem and within a year the problem came back. Clearly a design flaw.

New Member

Hi Jim,


I have the same problem!  You said you did more testing etc before it came right.  Do you think anything you did had anything to do with it starting to work again?




First Poster

Hi guys,


Same problem on my Samsung UE40D5520. Identically with the description given by Jim, the TV can not be controlled from remote or from the digital buttons. 


It is clear that this is a SW issue. I take a look under backcover to see if the capacitors from power supply board are damaged but everything seems to be ok. Both boards(PS board and Main board) are in perfect condition.


Could one of the moderators from Samsung advice us how we can fix this issue?


Thank you in advance for your quick feedback,



This boot loop problem has happend to me twice and both times it luckily came out of it. I was ready to throw it away as I thought it wouldn't be worth repairing though it was in perfect condition.

The things I tried to do to get it to start was to unplug all cables, it was left unpowered for a while. I opened the back cover to check the capacitors etc but I couldn't see anything wrong with it. I continually tried to restart it using just the power cable but it seemed hopeless. However, eventually it did start and I plugged in a powered aerial and selected the correct source and, luckily for me, it came back to life.

I don't know what the explaination is for it coming back to life, having tried a few minor, simple, things (as above), perhaps one of those things jolted it back to life. Is it a software problem? I don't know but I'm glad it's back to working normally and it has been since my original post.

Good luck to those that are having this frustrating problem.


New Member

Hi there, I have the same problem, as you can see in all our comments, there is no way to control the tv to search for any tv sw upgrade, we are not talking about cheap tvs, so please, help us Samsung.

First Poster

Hi Bluethug,


as you can see any of us did not received information about this issue from Samsung, but, in my case the solution was like this:

- I removed the main board from TV and send it to an electrician near Bucharest (Romania) via courier, he changed on the board an microcontroller that should be  reflashed or something like this. The problem was solved and my TV is working just fine now.


The cost was 50€ including transportation ( I am from Romania).

Top Liked Authors