Open search

Smart hub updating, try again later




I've had the smart hub update problem for 2 days: "smarthub is being updated please try again later". I've seen that lots of people have had the same problem and it's been suggested Samsung are deliberately blocking some customers to force them to buy new TVs. 

Is there a fix, or is it actually a scam by Samsung?


My model is UE32F4500 and my software is 2127. 


Some people have said they fixed the problem by doing something with the physical on/off button on the set, but my model doesn't have a button like that.

Advice please.


Hi @StillNotARobot 


Let's see if we can get this sorted for you. Could you try a Smart Hub reset? Go to Menu > Smart Features > Reset Smart Hub.


Let us know how it goes!


I am having the same issue.  I have reset the smart hub but this does not resolve the issue. 

I have tried pressing apps but same issue. 

I have also tried the mute Info type combo. 

My Samsung only has a small joystick type control on the back. 

model is UE465500


Hi there


I am having the same problem. I have tried the reset smarthub idea but it has not helped. My TV model number is UE32F4500. 


I have also also tried updating the software via the menu options, but I receive error message: 800 resource error. 


Any ideas?




Same problem here - and this seems to widespread, as there are loads of posts in this forum reporting the same problem has appeared in the last couple of days.


For me, the software updated to version 2127, and now the smart features don't work.


"Smart hub is being updated. Please try again later."


I've reset the hub, factory reset the TV, tried everything - but nothing works. 


Interestingly, when I look in the smart features menu, the "Samsung Account" option is greyed out - selecting it brings up the message "This function isn't available".


Why has my smart TV suddenly become un-smart? Seems to be a common issue with Samsung TVs. 


Tried that. For the sake of time, please assume that I have tried everything so far suggested by the thousands of other people who have experienced this problem. 

Obviously Samsung has created a software update that is incompatible with a lot of their models. Either it's by accident, and they must fix it immediately, or it was on purpose, and they are corrupt. 

Please advise. 


ChrisM, a response to my response would be appreciated.  Do you have a solution to propose for me and all the others on this thread that has not already been tried and failed?


Hi all,


The steps that we've been advised:


1. Power the TV off at the mains.

2. Wait 30 seconds.

3. Power the TV back on.

4. Wait 5 minutes, during which time do not press the Smart Hub button.

5. After 5 minutes, press the Smart Hub button.

6. Do not try to launch any app from the "Recent" section.

7. Navigate to "Featured".

8. Click on the "Apps" tile in "Featured".

9. For one time only, launch Apps from the main Apps panel.

10. From now on, it's okay to launch Apps from the "Recent" section.


If the issue is still happening after this, please get in touch directly with our TV Support team.




@StillNotARobot , @Hm9887 , The joystick controller doubles up as a physical power switch if you press the central part. (Samsung Hong Kong explains the joystick controller here if you need a bit more info on it.)

 Say "Hello!" to the Community in The Introduce Yourself Thread.

Doesn't work, unfortunately. There are no apps in the main app panel. They have all disappeared.

Can't launch apps. Samsung account greyed out in the the "smart features" menu. Nothing works since the last update.

Agreed with last post. No apps to select anymore. 

Just before Xmas as well. 

Top Liked Authors