Open search

Smart hub stuck at updating

First Poster



my smart hub on my Samsung tv (UE32J4500AKXXU) is stuck with the message - smarthub is being updated please try again later.


i have tried a factory reset (menu - support - self diagnosis- reset)


i have tried the smart hub hub connection test ( menu - support - self diagnosis - smart hub connection test) 



i have tried resetting the smart hub (menu - smarthub - reset smart hub)


all t+c’s have been agreed to all times ( both via accept all and individually checked)


There are currently no software updates available for our tv


nothing seems to be working. Any advice would be greatly appreciated 


Hi @Sirano1981 


Could you let us know the current software version of your TV? Go to Menu > Support > Contact Samsung.


Same problem like many ppl and no fix... the authorized repair shop told me they had to swap the motherboard which off course I refused as I won't pay for this known out of memory smart hub is updating problem thing from samsung that many ppl have for years on many different samsung Dumb 4K TV's when I know the motherboard is good but they just don't have any kind of memory clean function, no data access, everything is lock, no recovery modes, not even FW reinstall...


And my TV is on latest FW and I have tried everything already, but all smart hub apps are gone, I only have Browser and the e-manual, the rest of the default apps are grayed out and can't install anything as it just says smart hub is updating while it clearly shows 1GB used 0KB free and no way to acess this data or clean it...


Some have luck with just reseting the smart hub or changing it's region and it fixes the problem, but I think they probably didn't have the memory completely full like mine and I didnt even installed any single app, the TV just uses all the memory which already comes basically full out-of-the-box on day one with a few MB left and at some point it get's to 0KB left...


Even my cousin bought a samsung 4K this year a few months ago and just like my old samsung it still comes with 1GB total memory and only a few MB left, probably at some point in time her TV will also become a dumb TV like mine and like many other people and samsung does nothing, they want you to pay for a new motherboard each time the memory gets full and can't update the smart hub in case reseting doesn't work...


If out of warranty = we have to pay a full new motherboard because of maybe a 0.5$ 1GB memory chip that is full for their bad design of low memory, no recovery modes, no data access, no memory clean up function, no nothing...


Hope someone would sue them so they could finally update all TV's and fix this problem for good, I'm very pissed and my next buy won't be samsung when I have a total of 4 Samsung TV's and a samsung 1080P Led LCD monitor and I even still own a old big samsung CRT monitor, I'm out for good with samsund, my next buy will be OLED, don't even care for samsung upcoming QD TV's or even their perfect super expensive microled TV's, I'd buy if the brand said anything but "SAMSUNG"...


Was this ever resolved? I seem to be having the same issue. My TV UE32F5500 has been updating for 3 days now...


Please please help

i can’t cast or send my phone to my Samsung tv either now it’s stuck on updating for 5 days it’s useless I’ve tried every reset , smart hub , full system , wife reboot terms n conditions checked etc hard reset nothin is working and it’s really frustrating tv is only bought in 2015 and already they’re saying it’s too old so I need to upgrade it worked fine last week 

Same here, my TV is from 2015, bought in 2016 and nothing so far worked, they wanted to replace the motherboard just for the memory being full which I know it's not a hardware problem...

I just didnt try was a "Wife reboot", but I don't think that would ever work for the TV LOL :).
First Poster

I've been struggling with this problem today but just managed to resolve it!


My Samsung TV mode number is UE32F5500AKXXU.


I performed  a factory reset via the service mode feature by taking the following steps:


  1. Turn off TV with remote control.
  2. Wait a few moments.
  3. With the remote control press the following keys in sequence: Info -> Menu -> Mute -> Power. I repeated this twice and the Service Mode screen then appeared.
  4. Select the 'Option' menu item.
  5. Select 'Factory Reset'.
  6. Wait for the TV to restart.
  7. After 30 minutes the TV had not restarted so I turned it on with the remote and I was presented with the setup screen.
  8. Followed the setup.
  9. Went to Smart Hub to find all my apps back and working!
  10. Instead of watching Netflix I then wrote this! 

A mixture of these posts helped me along the way:

I'd tried all the things you'd listed and had also spoken to Samsung Support who accessed my TV remotely but failed to resolve the problem. Samsung thought my internet connection was the problem as it was showing 0.0Mbps while they were connected to my TV. I also tried a manual USB firmware update but it matched the version installed so failed. I download the firmware from here in case anyone needs it:


I hope this helps.


I am trying this now as have spent 3 days trying to resolve this issue. Very frustrating. Fingers crossed this works.

You, my darling, are a star! Worked perfectly. I am so happy.
I appreciate your help very much!!

Another person thinking your a star. After a frustrating few days your instructions were spot on. Thank you so much 

Top Liked Authors