Open search

Smart hub is being updated. Please try again later.


Hi my samsung smart tv is suffering form this problem for a month now. Can some tell me how to fix this? 


Unfortunately, nothing helps with my, tv 50j6240. No application after smart hub reset, the smart hub function is still being updated.

1GB internal memory full, 0 memory available.

1530 software

I did a reset from the service menu,

Eeprom reset does not start as it tries to do it according to the advice from the forum, tv is to be turned on or off when I press on / off?

I also did a reset in the svc options. Nothing helps... help


My TV is showing  smart hub is updating  for 2 days. Can't use any apps. Was going to do reset by pressing tv on off button  and remote on off but my TV dosent have one...model #  un65hu7250


I'm having the same issue 3 days now, tried a reset but still no joy!


Same exact problem... I have tried basically everything including go to a authorized samsung repair center where I paid 30€ just for them to check the TV and they said they needed to replace the motherboard which off course I refused, this is a known samsung problem that I see lot of ppl having and no fix and we are the ones who have to pay... The repair shop ended up giving me 10€ back since they basically did nothing and never had to open up the TV since it's only software all they probably did was go into the service menu change a few data and not much else...


No way to access the memory, no function to clean it, no Recovery Mode like many devices have, NO NOTHING, my next buy won't be samsung, like everyone says the only way to fix this problem is really never buy a samsung again...


My TV is UE43JU6060K and is on latest FW 1530.1, the TV reports 1GB used 0KB free and smart hub is updating...


I already did all kinds of resets including the ones on Service Menu, I already tried the ON\OFF button which does nothing on this TV, I already did smart hub reset many times, already changed Smart Hub location many times and nothing works...


I heard we can bypass the smart hub is updating garbage by blocking domain, but sadly my crappy router doesnt even support site blocking to test it, but I don't think anything will fix the out of memory problem that Samsung should have fixed, wish someone would sue the samsung B A S T A R D S and they should be obligated to updated all their smart TV's and finally fix this garbage...


PS: Now my Smart TV is beyond a dumb TV since it cost way more than a dumb TV in 1st place and now is a cheaper more expensive dumb 4K Samcrap TV...


So this is a Samsung forum where is the moderator or Samsung support here???

First Poster

We are suffering this same glitsch

What is the solution please?


The model number is UE32F5500AKXXU

We have had it since 2013 without any problem like this


The model number of our TV is UE32F5500AKXXU

Bought in 2013

What is the fix please?


Same problem. Seems to have started when software updated to version 2127.


All apps gone. Smart features are dead. "Smart hub is being updated. Please try again later."


Worth noting - in the smart features menu, the "Samsung Account" option is now greyed out. Selecting it brings up the message "This function isn't available". 


I have the same issue. No smarthub apps working, account area greyed out. Have tried all the 4 different resets, tried changing from UK to Ireland domain and back. Nothing works. Really frustrating. Have had it for 3-4 days. Tried phoning Samsung and was over an hour waiting in a queue but then had to leave. Any ideas or solutions? Where is Samsung help or moderator on this thread? This is a Samsung issue. Kids will be so disappointed if we don't have a tv that works over christmas. Really wanted to show my oldest his first Christmas film on Amazon prime! 



Top Liked Authors