Open search

Samsung tv stopped reading usb drives

First Poster

I have a Samsung UE55NU7023 i was playing back content just fine today and after i ejected my usb stick and insterted after 10 minutes without doing anything that would cause trouble my tv stopped loading anything from the usb port. It kep loading the usb forever when i tried to access it. I tried multiple usb sticks and it did the same thing. But when i had a single folder with a video in one usb drive the tv prompted me as always to play the video without opening the files and it played the video just fine, but when i tried to access the files after that i couldn't. What is going on? The port clearly works, what should i do? 

204 REPLIES 204

Hi all, 


So, after it fixed itself, my TV is once again not reading my USB drive. However, this time it seems like the TV is just not reading the one drive formatted with ExFAT (the other FAT32 drive seems to work). Anyone else having this problem?


I am disappointed in Samsung too .. My 4-year old 65" 4K UA65JS9000WXXY Samsung TV been having this problem with reading the USB sticks / external drives just recently .. I did tried everything with No luck .. sometimes it reads the USB stick and will continue for the night, but the minute you switch off the TV, you are done! .. its then a hit and miss whether it will read it again or not.
Tried different USB drives (about 5), even switching the TV's power from the outlet, resetting the TV to default setting ..
Almost tried everything! .. I am going to try one last trick of updating the firmware, despite the TV says it has the latest # 1530 firmware , however I just downloaded the 1.5GByte firmware 1530 file from Samsung Australia website, and will put it on a USB stick (!!!!! that's assuming it will read the ***** stick anyway :D) and will see if it works ..
I am over this issue with Samsung, and will consider selling the TV cheap and go LG OLED if the firmware does not work.

JesseW .. this is not a fix! ... There is a good reason why recent USB drives are formatted in NTFS and ExFAT , and not FAT32 !
FAT32 has a limitation of maximum file size of 4 GBytes only ... While with NTFS, the maximum file size is 16 TBytes, and with ExFAT its even bigger with 16 EBytes (Exabytes).
The FAT32 is OK if all your movies are low resolution 720 or low 1080p ... but with a 4K UHD 2160p movie you will likely exceed the 4GB limit of the USB drive and you will not be able to copy it in the first place.
First Poster

I have TV Samsung UE40F6400 with the same problem with USB as Chrislsk in begin of this blog.
I have TV with latest firmware T-MST12DEUC_2126.0.
In my case help me this:
1. Turn off TV (not only with button, but I pulled TV out of the energy socket).
2. Wait more about 30 minutes (this is very, very nessesary step!).
3. Turn on TV again.
4. Goto to the "menu, support, auto diagnostics, refresh.
Thats all, my USB ports are now OK again.

I hope I helped you !


Well, Hello everybody,


Same problem here, out of nowhere. I have UE55JU7000, software version 1530. The drive is recognized, but stuck on “Loading...” forever. It works fine on UE32J5200, which is usually slower.


Big thanks to kadous, following the steps actually helped. #2 is true, I tried waiting for about 10 minutes first, the usb loaded, but wouldn’t display all of the files and only play mp4 and avi files (none of mkv). Then I unplugged it for a whole hour just to be sure. It still doesn’t display the content properly (mostly it’s just white space), but I’m able to watch what I wanted (I have to skip blindly looking for the right file, though, because the titles aren’t showing). I’m hoping Samsung is fixing it soon. 


Hey folks, 


So I think this may continue to be a recurring issue unless Samsung takes care not to release updates without addressing it first. My USB issue once again solved itself, so I'm assuming they just don't check for this particular issue after updating, and then patch it afterward. Which is irritating, of course, but at least--for me, at least--it seems to get fixed eventually. (And yes, I'm able to watch very large exFAT files again...)



After making it work by resetting to factory settings, it stopped working the next time I tried to use it. Really annoying. 

Got the same issue with my Samsung. Highly annoying!

All items are listed on USB connections

Xfinity and Dvd 

Both say to power up device, not connected

They are on, hooked up correctly , and still nothing.

All of it worked fine last month


Last message was for HDMI & USB

Top Liked Authors