Support

Open search

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

Highlighted
SOLVED
Apprentice

Hello,

 

I am trying to fix my parents Samsung TV F6500 which has stopped connecting to Internet since a few weeks. Here is my diagnosis: The TV won't connect to Internet using wifi or Ethernet throught their usual provider. When I use my 4G phone as an access point, the TV connects normally.

 

These are the solutions I have already tried and that didn't work:

- Reseting the ISP's router + changing it's IP adress

- Factory reset of the Samsung TV (using the Auto-diag menu and the secret menu that you access pressing different buttons on the remote)

- Changing DNS to 8.8.8.8 or 8.8.4.4.

- Updating the firmware

- Calling the ISP's hotline

'

My questions are :

- Is it possible to do a factory reset that includes the Network connections?

- Has anybody had the exact same issue as my parents?

- Even after the factory reset, the TV continues to say that the firmware is up to date, is it possible to remove the updated firmware?

 

I am out of options and the Smart Hub is now useless. Any help would be greatly appreciated!

 

 

 

484 REPLIES 484
Highlighted
Yeah. This did not work for me.
Highlighted
First Poster

Hi, I was reading your post and was wondering if you ever got the TV to work. I am having the same issue

Highlighted
Hi. Yes it seems to work. My sky modem is 2.4ghz and 5ghz. I also have a range extender as the signal is weak over distance which also switches between 5ghz and 2.4ghz. I think the tv cannot switch between the 2 frequencies. So on the range extender I switched 5ghz off as further away from the TV than the router.
So the tv only picks up the signal from the sky modem and seems to work. I'm not sure if that makes sense.
If no luck I connected my modem by WPS to the tv instead of using password. It connected quickly and easily.
I hope it's fixed now. Goodluck!
Highlighted

Hi. What worked for me was the suggestion from on of the members of the community to hold the power button on the remote until you see the Samsung logo. The red light flashes too. Then turn the tv on. The tv reconnects to the internet. It’s worked ever time so far for me. But I have to do this every time I turn the tv on and sometime while it’s on. I won’t be buying another Samsung tv! 

Thanksfully I didn’t have to do some of the more complicated fixes like splitting the router which I wouldn’t have a clue about how to do.

hope it works for you

Highlighted

Your suggestion didn't work for me. Only renaming de 5ghz name in the router. Once you do that you don't have to use your fix anytime you start your tv. Good luck 

Highlighted

If other methods such as soft reset (holding down remote  power button until logo appears) you could try switching off Tv for a minute and rebooting router, factory reset Another idea is to change the DNS settings. Go to Network-Network Settings-DNS Settings. Change from Automatic to to 8.8.8.8 or 8.8.4.4.

 

Splitting wifi Bands which has worked for  some is not actuallly too complicated for the average user, though know some more confident than others. Dual Band routers will usually automatically select the strongest network  but you can change this in the settings. See more information here https://gizmodo.com/why-your-router-has-two-wifi-channels-and-how-they-work-1828650288 

 

 

Highlighted

This is a story of success. I think I almost started this strand - no not so, many before me had this problem of the WiFi connected but not the internet.  A couple of people told their successful solution was a new modem/router.  I tried everything that everyone else suggested with no success so ordered a new modem in desperation. Yesterday my new modem was installed and I am super super super delighted to say everything now works like a dream. After months I had tears of joy with the success. My internet service provider told me the 5 year old modem I had was simply outdated technology now.  With upgrades happening all the time I get it; now the next time I have this problem I will quickly get a new modem. Simple.  I strongly recommend this to everyone.  No more heartache.  Its not the TV. It is not Samsung.

Highlighted

@150DotAve wrote:

I've tried many different "fixes" to try and resolve the problem. Came across a trhead that suggested holding down the power button on the remote unit the TV reboots. Tried it and it worked. TV has been connected since without issue.


 

Highlighted

I tried this and it did not work =(

Highlighted

Check out my post...

https://eu.community.samsung.com/t5/TV/Wifi-Stopped-On-Smart-TV/m-p/1661960#M37893

This is the answer to your problem... Still working months in now!

Hope this helps.

Top Liked Authors