Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

(Topic created on: 17-07-2018 12:09 AM)
2491238 Views
Bobik
Apprentice
Options

Hello,

 

I am trying to fix my parents Samsung TV F6500 which has stopped connecting to Internet since a few weeks. Here is my diagnosis: The TV won't connect to Internet using wifi or Ethernet throught their usual provider. When I use my 4G phone as an access point, the TV connects normally.

 

These are the solutions I have already tried and that didn't work:

- Reseting the ISP's router + changing it's IP adress

- Factory reset of the Samsung TV (using the Auto-diag menu and the secret menu that you access pressing different buttons on the remote)

- Changing DNS to 8.8.8.8 or 8.8.4.4.

- Updating the firmware

- Calling the ISP's hotline

'

My questions are :

- Is it possible to do a factory reset that includes the Network connections?

- Has anybody had the exact same issue as my parents?

- Even after the factory reset, the TV continues to say that the firmware is up to date, is it possible to remove the updated firmware?

 

I am out of options and the Smart Hub is now useless. Any help would be greatly appreciated!

 

 

 

Go to solution
594 REPLIES 594
JakevsSansung
First Poster
Options

I faced the same thing after replacing the home router/modem.

Long press on TV on/off button did not help. 

Static IP on TV also did not help.

What did help is setting static IP on the TV AND setting the same static IP in the home router/modem (each separately did not work - tested it).

While both configured, checked and the tv was connected for several hours (more than 8).

0 Likes
JakevsSansung
First Poster
Options

I faced the same thing after replacing the home router/modem.

Long press on TV on/off button did not help. 

Static IP on TV also did not help.

What did help is setting static IP on the TV AND setting the same static IP in the home router/modem (each separately did not work - tested it).

While both configured, checked and the tv was connected for several hours (more than 8).

0 Likes
James Lang
First Poster
Options

I had the same problem. Few of the solutions listed here worked for me: https://www.techieinsider.com/samsung-tv-wont-connect-to-wi-fi-fix/


0 Likes
TA1977
First Poster
Options

SOLUTION: 

After trying (for hours) everything here and elsewhere, nothing worked. I discovered a bizarrely specific route to re-establishing a Wi-Fi connection that fixed the issue of failing to connect to Wi-Fi.

1) Go into your router's settings
This is usually accessed via 192.168.1.1 or 192.168.0.1 from your browser

2) Navigate to your Wi-Fi name/password settings
I use a "guest network", so I had to go to that specific area of the settings

3) Change the Wi-Fi name to something else, and remove the security authentication so there is no password (it's usually a "None" option that removes the password input box). 

4) After saving the changes and waiting for them to take effect, your Samsung TV should be able to connect to this newly named, open Wi-Fi network.
There shouldn't be a lock symbol next to the Wi-Fi network on your TV. If there still is, you didn't remove the security/authentication. 

5) With your Wi-Fi settings page still open, change the Wi-Fi name back to it's original name and save settings
But, don't enable security/password authentication just yet. 

6) Connect the TV again to this Wi-Fi network

7) Again in your Wi-Fi settings, you can now enable the password authentication, and add back the original password, and save the settings.

😎 After changes take effect, connect the TV to the network using the original Wi-Fi name and password. 

This was the ONLY way to connect my TV while using the original Wi-Fi network name and password (very useful if you have multiple devices on the same network/password)

For whatever bizarre reason, if I skipped or did any of these steps out of order, the connection fails. You can't just open the network up, then close it. You have to change the name, open it, connect TV, change the name, connect TV, add password, connect TV. Very, very strange. 

Anyway, I hope it works for someone else. 

0 Likes
abdukarimkhon90
First Poster
Options

Thank you so much. It worked. My TV was not able to find any WI-FI connection.

I reset all the settings including Smart Hub. And then manually changed IP address to 192.168.2.101, Gateway: 192.168.2.1, DNS Server 208.67.222.222.

Then my TV was able to find WI-FI and router.

Where from did you get this DNS server number? )))

0 Likes
Giusi5
First Poster
Options

thanks it worked 

0 Likes
Edlartys
Explorer
Options

I have this issue long time and the thing helps me to connect WiFi Was, pressing the WPS button on your router. 

0 Likes
LauriM
First Poster
Options

Thank you!! This worked for me! 

0 Likes
BigSteakOmlete
First Poster
Options

Somebody already said this but I wanted to confirm it. I had the exact same problem about 5 minutes ago. Hold down the power button on the remote until the TV reboots. After that it connected to the internet just fine. I didn't have to unplug it or change any setting. Worked like a charm. 

0 Likes
Mr Mauro
Apprentice
Options

Different Samsung TV, but same problem. It can't connect to my network with WPA2/WPA3 on a FritzBox!

Dozens and dozens of devices are connected to it without any issue... Except for the Samsung TV! To make it work I have to "downgrade" it to WPA/WPA2!!! That looks like some sort of bug of Samsung TV because it is then after all connected with WPA2 😞

0 Likes