Support

Open search

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

Highlighted
Apprentice

Sorry but I'm not sure. To be honest I am not familiar with the app.

Highlighted
New Member

Hey .. I ahve the same problem.. did you find any solutions?

Highlighted
First Poster
I did. It seems to resolve the issue whenever I pull the power plug from the back of the unit, then reattach it.
Highlighted
Apprentice

I returned my newest tv for another one. So far its ok but I have little faith. I purchased another wifi module for the other not so smart tv. Its very easy to change out so dont pay for it to be changed. Its sporadic as to if it will find a wifi stuck up its backside. All other wireless in the home works so I know its there. 

Highlighted
Apprentice

Returned the new one. I bought a new wifi module for the one i bought last you. Hit and miss reception on wifi signals

Apprentice

Thats not a fix. Its a reset at best. Will not last long. Samsung and their affiliatea problem. 

Highlighted
Apprentice

soooo. i've had PRETTY good success (as others have suggested) by going into my router and renaming the 5GHz signal a different network name.  I really think as others have suggested that it can't negotiate between the 2 wireless signals and gets confused.   about every 5th time i turn on my TV, it can't connect, but i use the other "fix" of holding power down for 5 seconds and it connects EVERY time, which is WAY better than it was before, so essentially:.... Renaming or turning off your 5Ghz signal and using the power button hold fix has worked for me, but i totally agree that this could be fixed with a software update and if samsung is listening:  PLEASE FIX THIS!?!?!!?!??!  thanks to everyone for helping me find a workable workaround...

Highlighted
First Poster
I took the advice to disconnect for a few minutes. I switched on and entered my modem password and was connected. Thank you for the advice.
John Woods,
Norfolk, UK
Highlighted
First Poster

I have the same problem and the TV it's a 55" 4k TV model 2017-2018...same problem all the time i start the TV i need to reconnect the wifi.

Highlighted
First Poster

Have you tried disconnecting the power cable then plugging back in?

Top Liked Authors