Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Samsung Smart TV Airplay function not working

(Topic created on: 21/06/19 10:35)
hud123
First Poster
Options
TV

I have just gotten a new update on my samsung tv 2018 version, there is additional menu "Airplay settings", however although its "on", my mac doest detect the airplay display. Both mac and tv are on the same WIFI as I can use chromecast.

 

I have tried to plug off the tv and turn on again, still the same, I am on update 1251.

TV Model : UA49NU7100

 

Any idea?

1 ACCEPTED SOLUTION
Solution
jsyc
First Poster
Options
TV

Hi all,

 

Just got off the phone with Samsung Support.

 

The reason why the Samsung TV does not appear as an airplay destination is likely because of firmware issues. As the new function requires new Airplay 2 functionalities. Older MacOS and iOS would not be able to see the TV as its destination.

 

The minimum MacOS and iOS required for Airplay 2 to work with the Samsung TV is (in-depth changes in the links copied):-

 

MacOS Mojave 10.14.5https://www.macrumors.com/2019/05/13/apple-releases-macos-mojave-10-14-5/

iOS 12.2https://www.macrumors.com/2019/03/25/apple-releases-ios-12-2/

 

After updating my MacOS to 10.14.5, Samsung TV appeared on my screen mirroring options immediately. Everything is working flawlessly now.

 

My only complaint is that Samsung Support does not state the minimum operating systems clearly in its Airplay support article (https://www.samsung.com/us/support/answer/ANS00082643/). I would recommend these additions so that we don't have to go on a wild goose chase attempting to reset TV in hopes of restoring Airplay functionalities.

 

Hope this helps!

View solution in context

101 REPLIES 101
Tridgida
Explorer
Options
TV
That’s how mine is set up. Still doesn’t work. Even the Dish guy can’t figure it out(granted, not a specialist).
0 Likes
Reply
samlover
Observer
Options
TV

Hi all,

I'm new here but having somewhat similar problem with my new Sam TV connecting to youtube using Airplay\BT with Code. When playing video file from youtube using Airplay\BT the Queue option is not available but it's available on my older Sam TV... would highly appricated for any help...thx

0 Likes
Reply
CWGuser
Apprentice
Options
TV

Really hate to tell you this...but these Samsung QLED's are overpriced and under-engineered. I took the other guy's advice and bought the LG's from Costco and Airplay works seamlessly. AND THEY ARE HALF THE PRICE.  Now I'm in the process of returning the other 8, yes 8!  that I bought. 8 new LG's coming in hot.  Samsung lost my loyalty on this one...  link to the LG that works with AirPlay: https://www.costco.com/lg-75-class---8-series---4k-uhd-led-lcd-tv.product.100509541.html

0 Likes
Reply
kmehner
Observer
Options
TV

Thanks so much for the update. I am currently having the exact same problem but my most current software is Catalina... any advice? 

0 Likes
Reply
Tridgida
Explorer
Options
TV

My advice is to buy LG. If it's still possible to return, DO IT IMMEDIATELY!  Sorry. I haven't found an answer, update to the software,  any guidance from Samsung. Nothing. I'll remember their customer service, also.  I'm sorry you are in the boat I am in. Good luck.

0 Likes
Reply
eliranfadida
Observer
Options
TV
Hey
Does it make sense that I do not support this app?
I purchased the product in 2016



MN : UE70KU7000
PD : --/--/----
SN : 09PU3SOHC00112T
FW : T-JZL6DEUC-1242.0
FC : SWU-OU_T-JZL6DEUC_1242_200130
MI : T-JZL6DEUC
LS : EU_ISRAEL
DI : MTCISIBY6PG2M
MA : E47DBD978E30
VS : 1242.200130
0 Likes
Reply
smitfits
First Poster
Options
TV

I know I'm late into this one but put screen mirroring in your drop down iOS Control Center. My iPad and Q65 kept air playing through Bluetooth alowing me to hear what I wanted to see. Mirroring is really what you want and easily excessivable on iOS.  

0 Likes
Reply
vmv86
First Poster
Options
TV

Hi,

 

I've Apple TV app on my Samsung UE55NU7093 (Software 1252), but I don't see Airplay icon on my Macbook Pro (Mojave 10.14.5) or neither my iPhone 6S (iOS 12.3.1) can't find television as an airplay destination.

 

All devices are in the same WIFI network and also I've enabled Airplay on my mac.IMG_3904.JPG

0 Likes
Reply
Megagabe
Apprentice
Options
TV

Hello. 

 

Airplay is separate from the Apple TV app. Think of The apple TV app as Netflix. Its a streaming service app. 

 

Airplay is part of your TV. It would be handled in your airplay settings.

 

Airplay is also only working on 2019 Samsung TVs (according to Samsung). 

They are working on fixing airplay for 2018 Samsung TVs. 

 

The reason you Apple devices need to be up to date is because it uses apples new airplay 2. Macs must be on Mojave and be airplay 2 compatible. iOS devices must be running iOS 12 and be airplay 2 compatible. 

 

To see if your devices are airplay 2 compatible. Call apple support and ask. Or search their support threads.

 

image.jpg

 

0 Likes
Reply
Jrmach
Observer
Options
TV

I shut off IPv6 and it started to work for me again... But then the Pc Stopped connecting. So I f I want to connect the windows pc I turn on IPV6. If I want to connect the airplay I turn off IPV6..

Go to samsung settings General network then expert settings and shut off IPV6....

Worked for me!!!!

pinewomble
First Poster
Options
TV

Was my VPN after all...

0 Likes
Reply
Tridgida
Explorer
Options
TV

I have no VPN. So, that not what's causing my iPhone and iMac from connectivity issue with the tv. The tv just isn't an LG. I'll remember this when buying another. 
#neversamsung

0 Likes
Reply
MahdiyyaHadjee
Observer
Options
TV

Hi. I have an iPhone X which is updated to iOS 13 and a 2019 Samsung Series Five smart TV. However my iPhone doesn't pick up my tv in its airplay settings. The WiFi connection is the same and Bluetooth is on. On the general setting bar of my tv, there also isn't the Apple airplay option, however under connection guide screen sharing option is there. Is there anyway to fix my problem 

0 Likes
Reply
Tridgida
Explorer
Options
TV

Samsung has the issue. They haven't replied to any of us about this situation. Buy an LG next time, I know I am. Bedroom tv is being replaced after 5 years with another LG. That tv(still working fine) is going down cellar to replace an older LG. Costco sale at Xmas sucked me in. Never again.

0 Likes
Reply
RobertKirchoff
Apprentice
Options
TV

Just switched from Q60 to a brand new LG 86". Best decision we could have made. It's weird.... everything just, works. No googling or forums. Just a functional TV.

0 Likes
Reply
lmmmm
First Poster
Options
TV

you might want to try turn the bluetooth on on your laptop and check the box for the bluetooth to show up in the menu bar. That did the trick for the airplay icon to show up in my menu bar

0 Likes
Reply
Soneji777
First Poster
Options
TV

Hi ,

 

i have samsung tv q60 qled tv. I am connecting my iphone to tv via mirror screen and its connecting fine but as soon as i do full screen its not working n it showing round n round . Can you please advice what i need to do?

 

thanks

 

0 Likes
Reply
ofg
First Poster
Options
TV

Searching online didn't yield any result. I promised I'll come back here if I'm able to fix it, and I did.

The problem was that I had the MacOS firewall enabled, blocking incoming connections.

What made me realize it is trying to cast from iTunes, which resulted in a more friendly error saying "your firewall is on".

Since this is a company laptop, I had to be a bit creative and disabling it, from the terminal type:

    sudo /usr/libexec/ApplicationFirewall/socketfilterfw --setblockall off

and type in your password.

 

Works immediately, have fun!

-OG

0 Likes
Reply
Tridgida
Explorer
Options
TV
I don’t have a firewall on my iMac or my X. How come, if you think of, it doesn’t work for me?
Again, personal equipment, zero firewalls, totally up to date.
Thanks,
Trish
0 Likes
Reply
Samsangairplay
First Poster
Options
TV

You have to make sure you are not on 5G wifi. I switched to 2.4G and everything started working perfect 

Tridgida
Explorer
Options
TV
Samsung shouldn’t force to fiddle with the modem to work with it. That’s just ridiculous. I’m not saying you are. Samsung is. LG is plug in and go. Won’t ever buy Samsung, again. I wish Apple made a tvs.
0 Likes
Reply