Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung Q90N no HDR in gaming mode

(Topic created on: 16-01-2022 03:01 AM)
MelvinSmiley
Journeyman
Options

HDR is not working when game mode is on. Even if VRR is turned off.

My graphic card is a Powercolor Red Devil 6900XT.

Here's the things I did:

  • Certified HDMI 2.1 Cable
  • Windows HDR Turned On
  • Input Signal Plus Activated
  • Resolution 3840 x 2160 @ 60Hz or 120hz, doesn't matter
  • YcBcR 4:2:2 12bit or YcBcr 4:2:0 10bit or YcBcR 4:4:4 10 bit in AMD Settings
  • 10bit Option Enable in Graphism Settings in AMD Settings
  • VRR Enable
  • TV Firmware Updated
  • AMD Drivers Updated
  • Windows 10 Updates Done

There are 2 Threads with the same problem but the solutions that were shown there don't work for me. In 1 thread apparently HDR started working again in gaming mode in Full HD, for me it still can't be turned on even in 1080p. And in the other thread they edited the extension block in CRU and added a Freesync 48-120hz range entry, which I already have.

Strangely HDR in gaming mode works again with when I run the Samsung TV with my Denon AV Receiver  but with this configuration I don't have VRR, which is why I use AV Receiver with E-Arc and my Samsung TV connected straight to the PC.

Maybe some handshake issue between AMD Card and Samsung Q90N?

 

11 REPLIES 11
Eyoyin
Journeyman
Options

Got the same problem I tried everything I can, even the only solutions found in the threads you mention but if I activate the game mode i can't have hdr, the games are beautiful if I deactivate game mode but no vrr and input lag so I would love to find something to resolve this problem...

I have a QN85A 55"

asus rx vega 64

 

MelvinSmiley
Journeyman
Options

My problem is solved, look at my edited post if you want. Don't know if it will work for you though.

Eyoyin
Journeyman
Options

Hey, thanks for your answer, but for me doesn't activate hdr it's not a pop up bug because in game i'm in bt.2020 or bt.1886 so no hdr for me 😕

MelvinSmiley
Journeyman
Options

Hm, it's the same for me, no st.2084 color space is available so it seems I was wrong. It looks close to HDR with HDR turned on in Windows for me but seems like it's no real HDR. My problem persists.

Eyoyin
Journeyman
Options

Hope they'r gonna do some update or something because it's disappointing...

MelvinSmiley
Journeyman
Options

Yeah, I will solve my problems by sending back the AMD Card. With my previous Nvidia 3070 everything worked fine. Still, you run into so many issues for having the audacity to use a TV with gaming features as a display for a gaming pc, it's no fun at all.

Eyoyin
Journeyman
Options

It's a shame to just to try to enjoy pc games and nothing works, hope you will enjoy your tv with the previous card !

MelvinSmiley
Journeyman
Options

Thanks, hope you can sort out your problem too.

qubit1337
First Poster
Options

I might have a solution for you, or anyone looking for a fix. This is what worked for me, i have a 6900xt.

First you need CRU Custom Resolution Utility

 1.turn off game mode from TV settings (very important step)

2. open CRU and edit Extension Blocks

3. delete  the 24hz / 30hz Tv Resolutions

4.  Add Freesync Range 48 - 120

5. Export CRU settings

6. Activate game mode from TV settings, open CRU and import the settings you just exported

7. Use restart64 from cru folder and you should have HDR and Freesync with game mode  on any resolution