Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung Q700t

(Topic created on: 05-11-2020 08:25 AM)
1319 Views
MagP
First Poster
Options
HI I purchased a Samsung Q700t TV. I have  connected  a Sony SVR-HDT500 Freeview HDD Recorder box to the TV using a hdmi cable.The TV scans for the box but I have no picture or sound, can anyone help.Thanks
0 Likes
9 REPLIES 9
Katniss
Pathfinder
Options
check if your cable is not tied to something or if you're electricity is fully running or check settings!
0 Likes
Katniss
Pathfinder
Options
that's all I can recommend sorry 😕
0 Likes
MagP
First Poster
Options
I have checked cable, and power all ok .Thanks
0 Likes
Katniss
Pathfinder
Options
good does it still work the sound
0 Likes
MagP
First Poster
Options
sorry what I meant was I checked the cable and power,these were ok.I still have no picture or sound on TV screen from box.Thanks
0 Likes
Katniss
Pathfinder
Options
check the BOX plug in and cable also 2 😃check
0 Likes
AndrewL
Moderator
Moderator
Options

@MagP: Are you making sure to select the correct source via the Home button? If so, try connecting your Freeview box to an alternate HDMI input to see if this helps, or connect using another HDMI cable. You may also wish to try Settings > General > External Device Manager > Input Signal Plus > Select the relevant input, to see if this helps at all. 

MagP
First Poster
Options
Hi tried all above still.Alll I have is a black screen.Thanks
0 Likes
Madelvic
First Poster
Options

Did you resolve this?   I've tried today to connect the same Sony device to a Q70R and no sound or picture (other than a brief message when the reset button was pressed).  Sony box works fine connected to an older Panasonic TV

0 Likes