Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung Q60T won't receive terrestrial channels

(Topic created on: 13-12-2020 07:22 PM)
Flaminrich79
First Poster
Options
TV

Hi 

 

I have just bought a Samsung Q60T and have just set it up. I selected Digital and Analogue channels, but the TV only finds the Samsung TV Plus channels.

 

I checked the source and its TV, I tried other channel categories (i.e. just Digital) and there was no difference. I saw one comment that under More Options I should select 'Air', but the TV didn't give me this option.

 

I have checked the firmware and its up to date. 

 

I have performed a factory reset and there was no difference. 

 

I have gone through most options on the TV and the Smart Things app and still the problem remains. 

 

I connected an old Panasonic TV to the same coaxial socket and it received the terrestrial/freeview channels immediately.

 

While I am planning on returning the TV, I don't want to find that I have missed a trick. Can anyone suggest any other options? 

0 Likes
4 REPLIES 4
PaulyWauly36
Navigator
Options
TV
should be searching digital only, not d and a,
0 Likes
PaulyWauly36
Navigator
Options
TV
u set it to uk and not ireland also
0 Likes
Noj_
Journeyman
Options
TV

Just worth a mention, some tv's (your old Panasonic) have better pre-amplification on receiving signals, sometimes digital signals won't show up on your tv if your aerial isn't up to the job either, hope this helps 🤞

0 Likes
Flaminrich79
First Poster
Options
TV

Yeah, I tried that as well and set the TV as being in the UK Region. Neither helped. 

 

As luck would have it (or Sod's Law), the thing has now decided to receive the channels. All the settings are the same, so I have no idea what helped...

0 Likes