What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung MU Series 2017 Smart TV's will do nothing after Samsung splash screen

(Topic created on: 20/08/17 16:06)

I have two 2017 Samsung MU series smart TV's (40" and 60"). Yesterday morning I tried to power them on. After the "Samsung Smart TV" start up screen you cannot access the TV, just a blank black screen.


both TV's less than two weeks old.


i phoned Currys and Samsung support who both stated that this is a known issue and a global fault on all 2017 MU series smart TV's. At present Samsung do not have a fix or a way of delivering the fix to effected devices. Apparently there are A LOT of effected smart TV's in circulation. Many many thousands of devices! 


My choices are;


1/. Wait for a fix

2/. Back to store for exchange of full refund


Is anyone else having this issue? 


Does anyone have an update about a potential fix and delivery method?


i don't really want to take them back as I like Samsung but if there is no fix I have little choice. The communication from Samsung on this issue is poor. Nothing on their website. 




*reposting this from the other thread here too*


Hi all.


There’s currently an over-the-network update that hopefully will get your affected M/Q series TVs up and running again.


For those who’re still awaiting an engineer visit, and if your TV  has remained connected to the same internet connection as before the recent troublesome update, can you try the below and let us know how it goes?



  1.  Power on the TV, and ensure a picture/video is displayed this can be terrestrial, set-top box etc. (Even if your TV has no picture/video displayed and you believe it was affected by the recent update, please give the following a try).


  1.  Leave the TV powered on for approximately 4 hours (this time can vary depending on Internet speed).


  1.  After approximately 4 hours, switch off the TV at the wall socket and switch back on after around 30 seconds.


  1.  Your TV should have normal operation restored. (Note: it may take a little longer to power on during the update writing process so don’t disturb the power as it’s doing that on the initial power up).


The above should force the TV to the latest update (version 1137.1).


However, if you’re not getting any joy from this, or your TV hasn't remained connected to the same Internet connection, then our TV Support team can still arrange for an engineer visit for you. (Any visits that have already been booked are still currently booked.) Definitely let us know how it goes, either way.


Also, I’d like to re-iterate our apologies for the inconvenience experienced.


*crosses fingers for you guys*

New Member

I am having this problem as of this morning September 1st in the US.  I called tech support and they were not aware of the problem.  Said they would send out an engineer.  I am afraid this will take a long time.  Please advise! Need this resolved asap!

First Poster

Same problem with UE55H6700SL, not sure if because of the software update. After powering on the TV, splash screen is displayed, red power on button flashes 4? times and nothing happens.

Have tried different remote control combinations suggested. Also tried the 4 hour on, 30s power out of the socet, power on combination - no use. Tried the latest firmware update from the USB as well but tv does not seem to boot from the USB stick. Cannot find more useful information from Youtube, no service manual - nothing.