Support

Open search

Removing Region Selection Samsung Smart TV

Highlighted
SOLVED
Apprentice

Every time I turn on my TV, 'region selection' pops up. I already completed it during set up, but it persists on each start up of the TV, which is very annoying. Does anyone know how to stop this? Thank you

54 REPLIES 54
Highlighted
New Member

Awesome, thank you! Worked a treat.

Highlighted

Thanks for the solution. All fixed now. 

Highlighted

Hello everyone,

 

So glad the provided solution turned out successful. Happy uninterrupted viewing to you all.

 

LMH

Highlighted

Many thanks for this.

 

After calling Samsung support and letting them take remote control of my TV for 20 mins they said they had done something that would fix the problem.

They failed.

 

Your answer sorted it for me.

Highlighted

:thumbs-up-sign-emoji-modifier-fitzpatrick-type: fantastic worked thank you 

Highlighted

Thanks for the fix, this has been irritating me since I got my NU8000 last week. 

I’ve turned off the auto return feature and will report back if it occurs again, hopefully not!

Cheers.

 

Many thanks. That one's been driving me up the wall... Not least because I couldn't do anything else until clicking the 'close' button, when it would take you to BBC One, regardless of what you wanted to do

Highlighted

I have a 9 Series with the same issue.  Unfortunately when I tried to follow your fix I found that 'Broadcasting' is greyed out and not selectable.  Any solutions to this would be much appreciated.

 

Thanks

Highlighted

I've just realised that Broadcating is only Greyed Out when I'm not viewing Terestial TV.  Once this is selcted as the input source it becomes available and then the Auto Tune During Standby option can be de-selected.  I think this is what is causing the 'Select Region' to be re-triggered following a re-tune during standby and perhaps finding a new staion for example which then requires a user input on switching back on.  Hope this helps.

Highlighted

That caught me out at first. The TV has to be set to receive a broadcast signal, ie Set to Live TV (Freeview) first. Then if you go to settings etc again, you’ll be able to access the broadcasting menu.

Top Liked Authors