Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

remove the Samsung TV Ad from homescreen

(Topic created on: 14-09-2022 04:55 PM)
74726 Views
autorick
Student
Options

I have recently bought a Samsung QE50Q60BAUXXU

Every time I turn it on or go to the home screen, a really annoying ad starts up for Samsung TV plus, "1000s of movies and TV shows..." 

Does anybody, for the love of god, know how to disable this?

(It's absolutely mad that an automatic ad is built into your own tv!)

49 REPLIES 49
topdavis
Journeyman
Options

This only worked one time.  Once the network services came online the Sponsored Content came back.

There is no Samsung solution for this and it has to do with the DNS used in the network connections.

If you have something like AdGuard DNS, the Sponsored Content won't work because AdGuard blocks the advertisements automatically.

You can also use OpenDNS as your DNS server and block ads.samsungads.com and point the TV to the OpenDNS DNS server.  I believe their might be more url's needed, but starting with the one mentioned should block most of them.

If you have a firewall, you can block  that URL, but it will block for all traffic through the firewall.  Pointing a device to a DNS server that blocks the URL will only block it for that device.

I think this is really bad practice by Samsung as I already paid them for the TV.  It's not like I am getting the TV for free.  If they give me the TV, then I'll suffer through the ads.

Jay122
Explorer
Options

I can confirm that I’m still happy that there’s no more advertising. The Home Screen looks like the 2nd photo attached to my previous post. The TV is online I’m only using it for streaming providers and AirPlay. No Adblock DNS service or whatsoever used. 

topdavis
Journeyman
Options

Maybe they changed functionality in firmware versions because I had to take an extra step for my newer TV. to stop showing the ads.

0 Likes
Adam Zappel
Explorer
Options

What steps? I tried what was mentioned earlier and failed. Still get the fakkkn ad every time

0 Likes
topdavis
Journeyman
Options

The steps jay122 layed out earler.  If you hold the power button and let the TV reboot, it wont have the Sponsored Ads.

On my set it inotially worked until the network came up, then the ads xame back.

IYou can confirm the ads are tied to network DNS settings by 

1 - DO NOT have any woreless or wires ethernet connectivity configured.  Reboot and the Sponsored Ads shouldn't come up at all. (You won't be able to stream, but this juat for testing)

2 - In my case, I use Adguard as my DNS server and point my TV to it.  Adguard blocks ads automatically so the never get to my TV. (You can do the same with OpenDNS, but it takes more work)

0 Likes
ThiagoBR
First Poster
Options

Thank you, the best simple solution I could find :smiling-face:

Adam Zappel
Explorer
Options

I did these steps yesterday and today didn’t see the ad. So far. 
Will update if it stays like this. 

0 Likes
grahamsh
First Poster
Options

I guess you found the solution or gave up by now, but since other people will find this thread here is the solution that seems to work to get rid of the ad APP at the start of the menu line.
Go to APPS and find the Privacy Choices APP (blue square). Open the app and press the Terms and Conditions button.
You are presented with a number of lines which are ticked to say you consent to advertising. Remove all the ticks. Do not tick the box - I agree to all. Save your choices. Exit the App. Hold down the power on/off button on the remote until the TV restarts. Hopefully like me your Advertising App has gone.


Nuggetnyc1
Student
Options

This did it!!! THANK YOU!!!

Adam Zappel
Explorer
Options

Yeah. This did it for me. Stayed like this foe a couple of months. 

0 Likes