Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

QN90B 50” - Game Mode not working

(Topic created on: 11-05-2022 01:20 PM)
11693 Views
Jeepster1
Explorer
Options

Ref:  Latest Samsung 50 inch QN90B 2022 model TV (QE50QN90BATXXU) with 144Hz VRR 4K being used as an external display via a HDMI 2.1 connection link from an AORUS 17X-YD PC gaming laptop with RTX 3080 internal graphics card inside.

 

The external Samsung 50” QN90B (2022) TV reports and shows the correct 4K resolution at 144Hz when connected to the HDMI 2.1 socket on the RTX 3080 graphics card (laptop).

 

NVIDIA Control panel on thenPC laptop reports and shows the correct 4K resolution along with the correctly set 144Hz…

 

However the issue is when putting the 50” QN90B TV setting into Game Mode ‘on’ for using VRR, because suddenly the source signal from the Laptop’s RTX 3080 is lost all together and the TV thinks that the computer is ‘off’ though it is not. Turning off Game Mode on the 50” QN90B TV results in the picture coming back and being received once again from the PC laptop at 4K 144Hz, but it is without any VRR (or G-sync).

I had a feeling the TV may have issues being so new from production.

 

Any solution, or is it a return job?

0 Likes
22 REPLIES 22
Eden Goldfarb
First Poster
Options

I found the solution for all the problems with qn90b displays (at least on 55 inch 120hz).

I used to own a qn90a display which worked perfectly with game mode hdr+120hz+vrr on windows 11 with rtx 3080.

Then after couple of months my display stoped working so i got replaced with qn90b model and then the nightmare of getting game mode work with pc started (while with PS5 it worked flawlessly)

I use hdmi 2.1 fiber optic cable which are capable of 8k60hz and will be more than enough for 4k 120hz (which also worked on the qn90a model...). sometimes the display worked fine but most of the time it would go besserk and after trying endless solutions (like formatting the tv, trying on every port...) the final solution is here:

You need to download CRU utility and change the display link speed to 40gbps instead of 48 (the highest link speed of HDMI 2.1) which the devices are not capable of, thus causing issues with game mode.

Its important to do so while the TV is connected in Game mode so you're gonna need another display to use as your primary for this

0 Likes
Jeepster1
Explorer
Options

That's interesting to know regarding the CRU Utility software, many thanks. However the issue appeared to be mostly resolved when I had previously posted in one of my replies (on 20 May 2022) that I had to perform a reinstall using the option for a "Clean Install" which also deletes "all profiles" - this action seemed to make all the difference.

Of course there are some settings within NVIDIA Control Panel that must be checked and changed after if necessary, regarding variable refresh rate and resolution (I described some of these within a reply on this post Re: Re: 50" QN90B TV (2022) extremely slow power-up time to Home Screen - Samsung Community ). As time has passed, the issue appears to have become a little better and smoother with possibly a combination of Windows updates, NVIDIA updates and Samsung TV updates helping with slightly better standardisation. Thus the only real issue is sometimes/occasionally not having flawless switching, in that both the TV and the gaming computer's laptop screen both being blank (black) - but the simple workaround for when this happens for me that is, is to press CTRL+F5 a couple of times and then ENTER. This is so that it cycles the display's projected output mode until the correct one is desired and then Enter key chooses it. Of course I'm doing this manual switching blindly, because it's on the occasions when both screens are blank - but fortunately this doesn't always happen.

Incidentally, I had downloaded CRU Utility some time ago for a different purpose. Back then I had an older 3D LG TV as it was rumoured that the 3D panel within it was capable of 120Hz supposedly and that CRU Utility could possibly unlock the standard 60Hz to that of a slightly higher refresh rate. But I never went through with it at the time and was worried that I may bork all the settings if attempting it.

Regarding that CRU Utility program; is it fair to assume that you can't permanently damage the settings and that one can revert them all back to how they were?

Lastly, although this issue was mostly resolved for me when I had done that clean install with deleting all profiles, I now ironically have an issue when connecting my Galaxy Tab S8 Ultra to the very same 50" QN90B (2022) TV via HDMI 2.1 cable connection. Previously I had enjoyed a super low latency connection from my S8 Ultra to the QN90B by using the cable link instead of the rather bad WiFi connection and furthermore I was enjoying 120Hz output onto the TV as well. However something happened at some point after some S8 Ultra Updates and now the cable link is terribly laggy with bad latency and only getting a 30Hz connection on the outputted display from tablet to TV - truly horrific! Obviously this is a different matter and I hope Samsung sort this out ASAP. What doesn't help much is that their is next to no customizable settings within the Galaxy Tab/Android System Settings when linking/mirroring to external high refresh display via HDMI 2.1

0 Likes
SkySong
First Poster
Options

Thank you, I’ll look for this “CRU” utility to see if that helps.  Also I’m seriously thinking about moving from AMD to NVIDIA, as the documentation i see out there makes me think Samsung TV has NVIDIA graphic cards in mind when they were designing the product to work with PCs. 

0 Likes
CorentiNoW
First Poster
Options

Hey !

 

Your solution seems good but how do you change the display link speed ? I searched everywhere and never found anything like that.

 

Thanks in advance

0 Likes
Blagnarok
First Poster
Options

I had the same problem with my laptop. It was pretty frustrating till I realized what was going on. The issue was that the laptop has "Optimus" mode, which is basically a mux switch that goes between the intel drivers while doing desktop work, and Nvidia's drivers during gaming.

To fix the issue, make sure you have it set to only use your Nvidia drivers on your mux switch. On my Lenovo Laptop, the setting is called Hybrid mode. You will have to restart your computer after changing this setting. Turn game mode on your TV and hopefully it will work.

If this doesn't work by itself, you will have to reinstall the Nvidia drivers with your TV plugged into your computer (not on game mode, so you can see the screen.) Do a "Custom Install" instead of an "Express" install of the Nvidia drivers, and select "clean install" option (it's at the bottom of the dialog box where you select what to install.) While the drivers are installing, turn your TV to game mode. The screen will be blank, but when the drivers install on the PC, it will recognize the TV and the game mode, and your PC should pop up on your TV in game mode with no more issues.

Just remember, it's the mux switch/Optimus mode/hybrid mode causing the issue. When you run on the Nvidia drivers alone, and not the intel drivers, it should be stable and let you have your VRR along with your fast refresh rate and HDR.

0 Likes
MongrelSlav
First Poster
Options
So after having the same issue i've found a workaround that so far hasn't failed. By using chrome screen share/remote access, i'm able to go into nvidia control panel from my phone whilst the tv says no signal & by simply reselecting the resolution (4k@144), it then connects & stays connected. Haven't yet tried with vrr/g sync but I'm up & running. This is deffo a software driver thing between samsung & nvidia. I'm using an rtx 3090.
0 Likes
Roms47
Explorer
Options

...after all time...on and off searching for answers, I stumbled onto a fix for me that had been stable all day and the TV playing PC games without any issues at 100 and 120hz.

​Input Signal Plus is obviously on for the Hz to climb over 60 and Gaming Mode is on for the Sound to work properly...for some reason the sound glitches when game mode is off.

Here are the setting that I changed to make it happen.
* Open the NVIDIA Control Panel
* Click on Adjust desktop size and position
* Select the Override the scaling mode set by games and programs
* Select Perform Scaling on Display
​* I'm using 4K - 3840 x 2160
* Set the Refresh to 100 or 120 Hz

At times the setting here changed, so to get it to stick to 100 Hz for now...I followed the following steps
* Open Display Settings
* Scroll down to Advanced Display Settings
​* Select 100 or 120 Hz in the Refresh Rate section...this seems to hold the setting steady.

I don't want to celebrate too much, but after multiple PC and TV reboots, this seems to have stuck and it working fine. I can see the framerate in multiple places...finally I can enjoy the TV as intended lol!

0 Likes
sasugajoker
First Poster
Options

I had a similar problem with this, and after trying many of the things suggested here I did not succeed.

My TV was set up fine but I accidentally unplugged the cable and for some reason, Windows or my GPU or whatever is responsible was not detecting the TV when I turned on game mode on the TV. Otherwise, I could use the TV with HDR but no VRR.

After trying many things, I noticed that turning on game mode and changing the aspect ratio in the game mode menu to 21:9 or 32:9 worked. There was obviously the issue of having a different resolution and aspect ratio, so I opened NVIDIA Control Panel and used the 'Change resolution' option to change it to 4K and now everything seems to be as I'd expect.

Now, I could be wrong and there might be something wrong with the picture, but as of now, I'm quite sure everything looks like it did before. The only issue is that the game mode menu still shows the aspect ratio I selected (32:9 instead of 16:9).

 

EDIT: I found that 2560x1440 resolution is missing 120hz support with the method I described, so it's not ideal. But might me useful for someone.

0 Likes
SkySong
First Poster
Options

Well I've been experimenting with the QN95B's Game Mode that does not work as advertised either.  With VRR enabled, I can get it to work in 144 hz 1080p and 120 hz 1440p, but it will not work reliably in 144 hz 1440p nor 2160p 144 hz.   

0 Likes
sasugajoker
First Poster
Options

I just posted a partial solution to my problem, which I edited the post to report that I found issues.

I tried booting into linux, and found that the TV worked fine there. I tried reinstalling my drivers again but to no avail.

I had noticed before that Windows 11 detects the TV but says it's not active in the display settings, but, at first, I didn't see anything in that menu to help me. I later noticed I could use the multiple monitor display behavior option (one that is shown in the screen position diagram and controls whether the displays should be duplicated, extended, etc) and I selected 'Show only on 1' (1 being my TV). This finally solved my problem, and after reverting to my preferred option of extending the displays, everything works fine.

0 Likes