Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Q90R - G-sync does not work with HDMI4 port - 4k/120hz g-sync not working

(Topic created on: 03-01-2021 10:12 AM)
Kansilehti
Apprentice
Options
TV

G-sync stopped working with Samsung Q90R's HDMI4 port when I upgraded to a Nvidia RTX 3080 gpu (It has two HDMI 2.1 ports).

 

I previously had a RTX 2070S (it has a HDMI 2.0 port) and was using Q90R's HDMI4 port + G-sync and it worked perfectly with 1440p/120hz and 4k/60hz. Q90R firmware was 1372.2.

 

Now with RTX 3080 I can set Q90R TV's resolution to 4k/120hz 4:2:0 (input signal plus, game mode and freesync ultimate enabled). This was on firmware 1372.2.

 

However when I enable G-sync and run the Nvidia Pendelum demo (or games) the TV's screen turns black and it loses the signal. G-sync enabled I've tried the pendelum demo at 4k/120hz 4:2:0, 4k/60hz RGB, 1440p/120hz RGB. All of these end up in a black screen when running the pendelum demo using HDMI4 port.

 

If I connect the same HDMI cable from RTX 3080 to Q90R's HDMI2 port then G-sync works at 4k/60hz RGB and 1440p/120hz RGB.

 

So I can't get G-sync to work at all through HDMI4 port anymore. Any ideas what could be the culprit?

I updated Q90R's firmware to 1374 from Samsung website. This did not fix the issue.

 

I have tried with 2 different HDMI 2.1 cables and the result is the same:
Club 3d Ultra High Speed HDMI 4K120Hz, 8K60Hz Certified Cable 48Gbps 1.5 m/4.92 ft
Hama Ultra High Speed HDMI Cable, 8K, 3.0 m

1 Solution


Accepted Solutions
Solution
Kansilehti
Apprentice
Options
TV

This issue is finally fixed with firmware 1381.2.

4k 120hz G-sync now works great.

View solution in context

0 Likes
19 REPLIES 19
Ju7ez
Apprentice
Options
TV

Did you get this sorted out in the end? I recently got an rtx3070 and am having issues with input signal plus. When booting my pc connected to hdmi4 the bios start up shows but then windows is a blank screen. If I turn off input signal plus and then re-enable it is fine. I can run games/windows in 4K/120 using 4:2:0 but it’s just the initial boot up that keeps needing to be tweaked in TV settings to keep it working. I too have a q90r (75 inch) latest firmware.

0 Likes
Kansilehti
Apprentice
Options
TV

No I did not. I just posted this message yesterday. 

 

Do you have G-sync working with HDMI4 port?

 

I actually can't see the BIOS screen at all from my PC with Q90R. It won't get video signal until Windows starts.

0 Likes
Ju7ez
Apprentice
Options
TV

I have not tried g sync yet. On the Samsung tv the only option is freesync which is for AMD cards but I believe the nvidia control panel will see this as a compatible g sync tv. Have you set your input source to game console? If it’s set to PC you will not have the option of enabling game mode or HDR etc. I am waiting for a new power supply as my new card requires a bit more juice and will let you know if I figure anything else out. Samsung has a guide for setting up the new RTX30 series cards and says that it should be compatible with the Q90R with Chroma Subsampling 4:2:0


https://www.samsung.com/us/support/answer/ANS00087803/

 

 

0 Likes
Kansilehti
Apprentice
Options
TV

Yes of course I meant G-sync compatible. Please test it and report back if you get G-sync to work with HDMI4 port.

 

I did not know you could change the source type on the TV. It was on PC mode the whole time. However with PC mode on I have set Game mode ON and Freesync to ULTIMATE. i don't understand if they don't work for you? I have not tried HDR because I don't think it is necessary for games because many games have a badly implemented HDR mode.

 

I tried changing the TV's source type to Game Console but this did not fix my G-sync issue.

0 Likes
Ju7ez
Apprentice
Options
TV

Thanks for letting me know.

 

I prefer HDR on with my desktop as the colours are slighter dimmer which is preferred.

 

Does it work without freesync enabled?

 

I remember getting 4K/120 on desktop but have not tried g sync yet. Also I didn’t think it was possible to get game mode on with input set to PC - the option was greyed out for me. Looks like you have a newer firmware although when I check for updates it says there aren’t any. I am on 1372 currently.

0 Likes
Udlet
Student
Options
TV

Hi,

 

I managed to get the g-sync to work when turning Game-Mode on when the input signal plus is turned off. The Game-Mode will force the input signal plus to work and it seemed to fix the issue.. very weird hardware behavior.

 

#using RTX 3070 with Q80T

0 Likes
Ju7ez
Apprentice
Options
TV

Thanks for letting me know are you running at 120hz/4K? I was able to put get pc mode working with game mode - just prefer the brightness of using source as games console. I noticed that when you enable freesync it disabled input signal plus and forces it on automatically. So are you good now in terms of playing games and getting to windows?

0 Likes
Udlet
Student
Options
TV

Yes. I can confirm I can play with RTX 3070 at 4k120hz 4:2:0 using HDMI 2.0. No issues when moving to desktop.

0 Likes
Ju7ez
Apprentice
Options
TV

I can’t seem to get 120hz working, I have the latest firmware rtx3070 and a decent 2.1 hdmi cable. Tried all the options, freesync on/off input signal plus but just can’t go above 60hz in 4K. Samsung say it’s possible with hdmi port 4

0 Likes