Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Q90 no signal

(Topic created on: 20-03-2020 05:49 PM)
484 Views
Prince46
Student
Options

Hello from Greece.. I recently bought a 55" Q90.. (About two weeks ago) Great TV! But I have an issue.. I connected my xbox one x everything OK.. But after a few hours later I lost signal.. 😕 Now, none of the hdmis work... I connected other devices but nothing.. Samsung support found nothing.. Now I wait for the technician.. I suspect one connect box or one connect cable.. Anyone facing similar issues? Thank you in advance and sorry for my English..

2 REPLIES 2
Pedpin
Navigator
Options

my new Q85 also with one connect box have a similar problem no HDMI work. Waiting for the support. 

Keep us informed about you outcome.

0 Likes
Prince46
Student
Options

Sorry for the delay... My TV was fixed! It was the one connect cable! I told them from the begining but they insisted to change me the board from the one connect box! They took the box and ordered new board (they wanted to take the tv too, but I don't trust them as I saw there is no treatment to the device so I refused them to take it) they left me without tv for days... When they brought the box back, guess what, no improvement! Maybe its the cable he said.. 😡 Wait more days, the cable came and voila! Everything works! They should test the cable from the begining.. He didn't even know the model! Technicians with no knowledge! So much hassle for such an easy fix.. What about you? Did you fixed your Q85? 

0 Likes