Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Q80T - Sky Q, Sonos Beam and Pass Through and lip sync.

(Topic created on: 26-10-2020 12:36 PM)
3324 Views
BarryChuckle
Explorer
Options

Ok so, I've had the Q80T for a few days and one minute I'm really pleased and the next I'm frustrated. 

Last night's problem was lip sync through Sky Q using Sonos Beam. Now, don't get me wrong, I know that there are loads of lip sync issues with Sky Q but this one is odd.

I managed to fix the majority of lip sync issues by setting all of the devices inputting into the TV to use Pass Through. All was working well until I watched a Ultra HD film from Sky Cinema using Sky Q box. The lip sync was horrendous. When trying to fix it, I found that pass through was changed to auto with pass through greyed out. So I turned off the film and then all channels were set to auto with pass through greyed out and nearly every channel was badly out of sync. 

In the end, I've had to unplug the Sonos Beam from earc, and plugged it back in and hey presto, I have pass through as an option again and the sync is back to normal. Proper faff. Gonna. Have a play and report back but anyone else using a beam with a Q series TV that can offer advice?

I don't want to listen to PCM sound as I want Dolby 5.1 or else there is no point having the Beam. 

This TV may go back if this persists along with the stuttering picture issue it's quite annoying. Real shame as the TV itself, when it works, is amazing. 

3 REPLIES 3
BarryChuckle
Explorer
Options

Have to point out that all other playback lipsync seems to be fine when pass through is available and selected. It was only when I played an Ultra HD film that it switched to auto and made the pass through option greyed out. The film worked fine through the TV speakers. 

Sky Q was always a pain on my old TV but that was only using the Sky apps of Netflix and Disney +.

My wife only has so much patience with me "playing" with the settings. 

0 Likes
nic20
First Poster
Options

Seems to be a common problem and Sonos has commented on this ... maybe this is something Samsung can address in future software updates ? 

 

"Some Samsung TVs have trouble processing high quality video and outputting Dolby Digital audio via optical at the same time. This can cause a lip sync issue where the video is ahead of the audio. Sonos players will play the audio as soon as we get it, with the option to add an increased delay on the audio if desired. But the player can't increase the speed in which it receives the audio, as that's handled upstream.

To know if this is what you're experiencing, there are some tests you can use:

  1. Change the audio output to Stereo, which should remove the delay. This is because the stereo signal doesn't need any extra processing and will output quick enough to keep time.
  2. Connect the Sonos device to something else, an HDMI switch as you mentioned is a good option, or a cable box or other device able to convert/output a Dolby Digital stream.

To solve this issue, if it's indeed with the TV's processing, the first thing to do is make sure there isn't any extra audio processing taking place on the TV. Sometimes there's an additional processing feature on the TV. For LG TVs, there's a guide here on their website with some suggestions that may help, also, make sure your TV is updated to the latest version.

If that still doesn't do the trick, you could reach out to the TVs support, or use a workaround, such as that HDMI switch option."

 

see link to above post https://en.community.sonos.com/troubleshooting-228999/lg-oled-audio-delay-2019-update-6827554

BarryChuckle
Explorer
Options

Hi there,

Thanks for that! All really useful information. 

I have found a strange solution by which I now have no delays. 

1. Unplug the HDMI for the beam

2. Plug in the optical cable adapter only. This tricks the TV into thinking I want to use optical and starts going through the setup. This fails as expected and the TV reverts to using built in speakers. 

3. Leave the optical cable adapter in the TV 

4. Plug back in the Sonos HDMI cable. The TV then uses this as the output. 

5. Select pass through in the sound options of the TV. 

6. Pass through then stays as default for watching UHD films through SkyQ. 

There are no delays. If I take out the optical adapter and try to watch a UHD film, I get delays and have to go through the above again. So, I'm leaving it whilst it's working and enjoying 5.1 surround through the beam at the front and Sonos one's at the back. 

Odd but works. 

0 Likes