Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Possible Fix for Too-Dark Netflix Videos on Samsung TVs

(Topic created on: 10-07-2019 10:26 PM)
100pat
Pioneer
Options
TV

Sadly, the answer is to switch your device to SDR. You can sit in a pitch black room and mess with settings all you want - that won’t fix it. 

This means that you have to notice, or know, that the video you want to watch will be streamed  in Dolby Vision HDR and change a setting every time (then change it back - what a pain!) to accommodate this. 

 

a) *EDIT* THE INFORMATION IN a) BELOW IS WRONG. I HAVE LEFT IT IN PLACE SO AS NOT TO CONFUSE PEOPLE WHO SUBSEQUENTLY RE-READ IT.  IT APPEARS THAT, FOR MORE MODERN TELLYS AT LEAST, THE OPTION ("INPUT SIGNAL PLUS" IN SETTINGS/ GENERAL/ EXTERNAL DEVICE MANAGER) FOR TOGGLING BETWEEN HDR AND SDR ONLY FUNCTIONS IF YOU ARE WATCHING VIA AN EXTERNAL DEVICE SUCH AS AN APPLE-TV OR A FIRESTICK.  IF YOU ARE USING THE TELLY'S OWN SMART NETFLIX APP THERE APPEARS TO BE NO OPTION TO TOGGLE BETWEEN HDR AND SDR. 

a) If watching via the Netflix smart app on the Samsung HDR telly itself, turn off the HDR settings in the telly’s General/ External Device Manager settings which set the input ports for HDR. Usually called HDMI UHD Colour or Input Signal Plus. (EDIT: NO, THAT WON'T WORK. )

Now the Netflix Dolby Vision HDR video will still play in 4k/UHD but only in SDR. (And only in 8-bit) But, at least, you can see it without having to sit in the coal cellar. 

 (May cause unwanted changes to other devices connected to the TV)

Remember to turn those settings back on again for non-HDR Netflix videos and for all Amazon etc. videos.

 

b) If watching via an AppleTV 4k connected to a Samsung HDR TV the following are usually the best Video settings in the AppeTV for everything except Netflix HDR videos. I recommend using them all the time:

- 4K SDR (Yes, SDR!) in 50Hz (UK) or 60Hz

- Chroma 420 (To enable 10-bit on most, not-super-expensive, Samsung tellys)

- Match Content > Range and Frame Rate both turned on. 

 

Now, to watch a Netflix Dolby Vision HDR video in SDR on a Samsung HDR TV, simply turn off Match Dynamic Range (only) in the Match Content setting referred to above. EDIT :SO LONG AS YOU HAVE SET YOUR APPLE-TV TO SDR AS I HAVE RECOMMENDED ABOVE. 

Now the Netflix Dolby Vision HDR video which you want to watch will still play in 4k/UHD but only in SDR. (And only in 8-bit)

Remember to turn that Range setting back on again for non-HDR Netflix videos and for all Amazon etc. videos.

EDIT: NOTE THAT, IF YOU ALTERNATIVELY ELECT TO TURN OFF HDR WHEN USING AN APPLE-TV BY USING THE "INPUT SIGNAL PLUS" SETTING IN YOUR SAMSUNG TV SETTINGS, THAT WILL WORK BUT THEN YOUR APPLE TV WILL SENSE THAT IT IS NO LONGER CONNECTED TO AN HDR TV AND WILL PROBABLY ALTER SEVERAL OF IT'S OWN SETTINGS. 

 

EXPLANATIONS:

Firstly, the “best” AppleTV settings shown above will allow SDR Videos and the Home Screen to display correctly and then, when you start to play any HDR video, the AppleTV automatically switches itself to output HDR ( and automatically back to SDR again, when done.) EDIT: UNLESS, OF COURSE, YOU HAVE TURNED OFF THE "MATCH RANGE" OPTION IN ORDER TO WATCH A NETFLIX DOLBY VISION VIDEO. 

 

Netflix outputs it’s HDR videos in Dolby Vision HDR format. Many brands of  telly display this OK but Samsung tellys are designed to use the rival HDR10+ format. Dolby Vision formatted videos display badly on Samsung TVs. Full stop!

Amazon Prime output their HDR videos in HDR10+ format so they display nicely on Samsung tellys. 

 

Netflix claim to output HDR in both Dolby Vision format and in vanilla HDR10 (without a +) format. Presumably, if we could get them to send HRD10 (without a +) format videos to our Samsung TVs that would fix the problem. But, I rang Netflix, and it seems (in a very vague conversation) that this is not possible unless our AppleTVs could somehow request it. 

 

Dolby Vision vs HDR10+. Who will win the battle to become the industry standard?

 

Note that this correct AFAIK on 08/10/2019 and may change in future. Those of us who just bought new Samsung TV sets will be keeping our fingers crossed!

EDIT: MY APOLOGIES FOR THE EDITS!

 

363 REPLIES 363
matteolel
First Poster
Options
TV

With latest update, Netflix is less dark, but not exactly as bright as from my PS4 disabling HDR... so I cannot consider that as fixed 😞

antonio243
Navigator
Options
TV

any news? netflix on hdr is still dark...

new firmware? 

0 Likes
Magpie90
Pioneer
Options
TV

I'll be getting a second Samsung technician  visit in about a month... post Covid  lockdown to help resolve issue...not holding my breath

0 Likes
Jicehix
First Poster
Options
TV

I've installed the update (1302) and there seems to be a slight difference, but nothing satisfying. Still dark as hell. I've also tried to plug in a Fire Stick 4K with forced 8 bit mode (thus theoretically disabling HDR) but the issue is the same.

 

I'm seriously considering returning the TV.

0 Likes
Magpie90
Pioneer
Options
TV

Before purchasing a new TV make sure you don't end up with the same problem. I've tried on a Sony and it isn't any better. The forum mentioned someone who refers to LG...I need to find that reference whether positive or not. However, under no circumstances should we be buying Firesticks, Apple TV devices, Playstations and whatever else to get a proper , clear " not too dark" picture in a Samsung TV. This is not a solution but an expensive workaround. For anyone interested here is a Sony v Samsung comparison with interesting comments on Dolby Vision v HDR10+ picture:

 

https://www.whathifi.com/advice/samsung-vs-sony-tv-which-is-better

0 Likes
Rameezsultan86
Explorer
Options
TV

Hi all 

so the update is now available in Portugal. 
like other users definitely it is a little better but not perfect. 
Ill test it later in the night as well and keep you posted but Witcher on netflix in now atleast viewable. 

0 Likes
matteolel
First Poster
Options
TV

Any news from samsung or netflix? this is very disappointing 😞 

MissGiGi777
First Poster
Options
TV

All I did was change the 'Contrast Enhancer' setting to High & this fixed my issue.

0 Likes
Domster
First Poster
Options
TV

I've found if you put picture setting on dynamic and then increase the shadow details settings it is better.

0 Likes
Drao101
First Poster
Options
TV

Returned my Frame 55  2020 model after it got a dead pixel in a month.

 

Bought the Sony x900h. No more issues, feel like the dead pixel was a blessing in disguise.

 

Finally Dv content is watchable like The Witcher in expected quality.

0 Likes