Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Possible Fix for Too-Dark Netflix Videos on Samsung TVs

(Topic created on: 10-07-2019 10:26 PM)
100pat
Pioneer
Options
TV

Sadly, the answer is to switch your device to SDR. You can sit in a pitch black room and mess with settings all you want - that won’t fix it. 

This means that you have to notice, or know, that the video you want to watch will be streamed  in Dolby Vision HDR and change a setting every time (then change it back - what a pain!) to accommodate this. 

 

a) *EDIT* THE INFORMATION IN a) BELOW IS WRONG. I HAVE LEFT IT IN PLACE SO AS NOT TO CONFUSE PEOPLE WHO SUBSEQUENTLY RE-READ IT.  IT APPEARS THAT, FOR MORE MODERN TELLYS AT LEAST, THE OPTION ("INPUT SIGNAL PLUS" IN SETTINGS/ GENERAL/ EXTERNAL DEVICE MANAGER) FOR TOGGLING BETWEEN HDR AND SDR ONLY FUNCTIONS IF YOU ARE WATCHING VIA AN EXTERNAL DEVICE SUCH AS AN APPLE-TV OR A FIRESTICK.  IF YOU ARE USING THE TELLY'S OWN SMART NETFLIX APP THERE APPEARS TO BE NO OPTION TO TOGGLE BETWEEN HDR AND SDR. 

a) If watching via the Netflix smart app on the Samsung HDR telly itself, turn off the HDR settings in the telly’s General/ External Device Manager settings which set the input ports for HDR. Usually called HDMI UHD Colour or Input Signal Plus. (EDIT: NO, THAT WON'T WORK. )

Now the Netflix Dolby Vision HDR video will still play in 4k/UHD but only in SDR. (And only in 8-bit) But, at least, you can see it without having to sit in the coal cellar. 

 (May cause unwanted changes to other devices connected to the TV)

Remember to turn those settings back on again for non-HDR Netflix videos and for all Amazon etc. videos.

 

b) If watching via an AppleTV 4k connected to a Samsung HDR TV the following are usually the best Video settings in the AppeTV for everything except Netflix HDR videos. I recommend using them all the time:

- 4K SDR (Yes, SDR!) in 50Hz (UK) or 60Hz

- Chroma 420 (To enable 10-bit on most, not-super-expensive, Samsung tellys)

- Match Content > Range and Frame Rate both turned on. 

 

Now, to watch a Netflix Dolby Vision HDR video in SDR on a Samsung HDR TV, simply turn off Match Dynamic Range (only) in the Match Content setting referred to above. EDIT :SO LONG AS YOU HAVE SET YOUR APPLE-TV TO SDR AS I HAVE RECOMMENDED ABOVE. 

Now the Netflix Dolby Vision HDR video which you want to watch will still play in 4k/UHD but only in SDR. (And only in 8-bit)

Remember to turn that Range setting back on again for non-HDR Netflix videos and for all Amazon etc. videos.

EDIT: NOTE THAT, IF YOU ALTERNATIVELY ELECT TO TURN OFF HDR WHEN USING AN APPLE-TV BY USING THE "INPUT SIGNAL PLUS" SETTING IN YOUR SAMSUNG TV SETTINGS, THAT WILL WORK BUT THEN YOUR APPLE TV WILL SENSE THAT IT IS NO LONGER CONNECTED TO AN HDR TV AND WILL PROBABLY ALTER SEVERAL OF IT'S OWN SETTINGS. 

 

EXPLANATIONS:

Firstly, the “best” AppleTV settings shown above will allow SDR Videos and the Home Screen to display correctly and then, when you start to play any HDR video, the AppleTV automatically switches itself to output HDR ( and automatically back to SDR again, when done.) EDIT: UNLESS, OF COURSE, YOU HAVE TURNED OFF THE "MATCH RANGE" OPTION IN ORDER TO WATCH A NETFLIX DOLBY VISION VIDEO. 

 

Netflix outputs it’s HDR videos in Dolby Vision HDR format. Many brands of  telly display this OK but Samsung tellys are designed to use the rival HDR10+ format. Dolby Vision formatted videos display badly on Samsung TVs. Full stop!

Amazon Prime output their HDR videos in HDR10+ format so they display nicely on Samsung tellys. 

 

Netflix claim to output HDR in both Dolby Vision format and in vanilla HDR10 (without a +) format. Presumably, if we could get them to send HRD10 (without a +) format videos to our Samsung TVs that would fix the problem. But, I rang Netflix, and it seems (in a very vague conversation) that this is not possible unless our AppleTVs could somehow request it. 

 

Dolby Vision vs HDR10+. Who will win the battle to become the industry standard?

 

Note that this correct AFAIK on 08/10/2019 and may change in future. Those of us who just bought new Samsung TV sets will be keeping our fingers crossed!

EDIT: MY APOLOGIES FOR THE EDITS!

 

363 REPLIES 363
Oppressa
First Poster
Options
TV

After dealing with this for months, I finally spent a session yesterday trying to fix it.  Tried resetting the TV and a myriad of other things.

 

I have a Home Theatre PC connected.  In the Properties of the display adapter I changed the refresh rate to 29 Hz.  All of a sudden, I could see darker scenes clearly.

0 Likes
Rhetorik21
First Poster
Options
TV

I am having the same issues with my Samsung 2020 55 inch, both Amazon Prime and especially Netflix are much too dark, The Alienist say is nearly unwatchable, but also the the streaming speed, 2.1mb(i have 37mps) is appalling, lots of grain, etc, etc, discussed this with Samsung support and was fobbed off, told to use expert and of course I have already, she took over remotely, but still offered no answer. Same with Amazon, no real joy(saying they are aware of the issue but no firm date, yeah right.), 

I should mention i have to turn the brightness setting up to 50 just to get an acceptable picture, even with terrestrial HD, you tube 4k can be incredible though, I wonder if it a design fault, quite angry tbh

0 Likes
paul126
First Poster
Options
TV

Problem still not resolved i see, tried to watch Loki last night on Disney plus and was unwatchable on my 2018 65 inch Q9fn Samsung tv, way too dark. Anyway reverted to using the App on my Sky Q box rather then the tv and the picture was perfect. Its the tv that's at fault. We had all the hype with Samsung not allowing DTS and now we have to put up with more ***** from Samsung, not good enough when you spend thousands on their TV's , well never again.

0 Likes
aceabe
First Poster
Options
TV

I thought it wasn't working only with Dolby Vision HDR? I've just tried on my Nvidia Shield and it's completely unwatchable with HDR10 AND HDR10+ material as well. I don't get it, it's CLEARLY stated my model supports HDR 10+ : https://www.samsung.com/be_fr/tvs/uhd-4k-tv/nu8000-55-inch-crystal-uhd-smart-tv-ue55nu8000lxxn/#spec...

 

Can someone please explain this to me?

 

Thank you!

0 Likes
paul126
First Poster
Options
TV

Go to settings on your tv,  picture , expert settings , scroll down until you get to Gamma settings and if it is showing BT.2084 change it to BT.1886 which switches of HDR. Your tv may have different settings setup but should be roughly the same just find the Gamma setup.

0 Likes
LetMeTurnOffHDR
Pathfinder
Options
TV

This doesnt work

0 Likes
paul126
First Poster
Options
TV

May not work for everyone but worked for me.

0 Likes
LetMeTurnOffHDR
Pathfinder
Options
TV

It doesnt work..it might look brighter but it washes out colors.

0 Likes
ikramkhasim
Pathfinder
Options
TV

Doesn't work for me either. Option is grayed out when HDR content is played. 

0 Likes
Magpie90
Pioneer
Options
TV

335D0F38-2462-4BEE-AF31-F01D80C4D819.jpeg

 No can do!

0 Likes