Support

Open search

Not turning on Apple TV via HDMI CEC after TVOS 13

Highlighted
First Poster

In TVOS 13 Apple changed the commands to turn on the (external) Apple TV. 

The TV is a 2018 Q9F model.

 

But now when I select Apple TV as input via the TV remote, the Apple it is not switched on (like it did before).  This has worked always, via HDMI CEC.

 

I suppose Samsung must do a change the firmware to send the new key sequence to the Apple TV,  to turn it on?

 

A workaround is to press the "back" button on Samsung remote (this sends "menu" key,  and is what now turns it on). But try to explain that to the rest of the family... :face-with-rolling-eyes:

 

Anybody has something else that works better?

10 REPLIES 10
Highlighted
Mastermind

Very good observation @NilsNoldus  thanks you for the info and we will need to explain to a Official Technics as a Moderetor here.

 

I do not understand why Apple changed id if you have the same buttons and the same Apple remote control...:thinking-face:

 

Could be interesting to know :face-with-rolling-eyes:

Highlighted

Absolutely having the same issue. I have a 2017 Q7f and an Apple TV 4K, I've been pulling my hair out thinking this was a TV issue, have performed multiple resets as well. Nice to know I'm not the only one having this issue. Do we know if Samsung are looking into this for the next update?
I'm on 2017.3 update (most recent). 

Highlighted
Im having the same issue and will be keen to know what the fix for this is
Highlighted

Mine works  OK but in the past I have found that the TV learns what to do CEC-wise and memorises it. Any change may make it start anew.

 

I have found that unplugging all power leads, pausing, then reconnecting leaving the TV to last with pauses between each reconnection works best. Sometimes I have repeated it several times! And then keep turning the ATV box on and off.

 

Swearing may or may not help. And even less helpful is my memory - TV first or last? Curses! My sympathies as it really is a pain - but it always works in the end. Maybe that's down to the swearing?

Highlighted

Same problem here - Samsung Please update even if it isn't your fault!

Highlighted

Same problem with ATV 4k and Samsung Frame 55" 2018. Also, my Samsung   no longer recognizes my ATV4k when I reboot, I have to manually configure and select that its a Apple TV.

Ive verified that all settings on my samsung frame and ATV are correct and both are updated with the latest OS/firmware 

Ive bought 3 different HDMI cables that all where promised to suppport CEC/Anynet+ and reboted, nothing helps.

Please fix

 

Highlighted

Same issue here. Nothing I do seems to get the cec working again. 

Highlighted
New Member

I'm using an Apple TV 4K - tvOS 13.4.8

and Samsung 55 Curved UN55JU6700 - version 1550

 

This just recently happened where my tv will not detect the Apple TV on Anynet+ (CEC). I disconnected the HDMI cables on both sides and even tried a new cable and input, the only thing I can think of is an Apple TV update that changed something. My Samsung TV hasn't had a new update in forever. 

I've only noticed this because when we put the Apple TV to sleep it doesn't turn off the tv like it used to. Also using my Samsung TV remote doesn't respond to moving around the menu or selecting apps either. Using the back button doesn't work as recommended in an earlier post.

 

Anyone find a different work around? 

Highlighted
I'm having the same issue. My Samsung television will no longer wake up/turn on with the AppleTV remote. This function was working before and just seems to have suddenly stopped. Both devices are currently up to date and have all necessary options " Anynet+"(Samsung) and " Control Tv and Recievers" (Apple) and no luck. Additionally I have reset both devices and have also had no luck. I have also replaced the HDMI  to a new one that does support CEC and no luck either. However, when I  unplug the Samsung tv and plug it back after 15 minutes , the AppleTV remote does turn on and off the Samsung tv, but will only do it 1 or 2 times and then go back to not working again. I've spoken to Apple support and the advisor was not able to help me and instructed that HDMI CEC is a hit or miss and they cannot control that. It's such a headache because this function DID work before and now seems to have stopped working out of nowhere. 
One possible solution I did find, is that the AppleTV allows you add third party remotes, and I've added my Samsung tv remote to function on my AppleTV, but it does not work perfectly. Most buttons seem to work volume, menu, home and the directional buttons;however, using the select/okay button will make the window on the Samsung tv that shows you what output you're currently on display every time. And turning on both devices with the one remote doesn't work either. To do this go through the AppleTV Settings > Remotes and Devices and select Learn Remote.

Hopefully this issue will get resolved soon, but so far I have not been able to come up with an adequate solution. 

Top Liked Authors