!-- End Google Optimize -->
Support

Open search

Netflix sound not working on UE50NU7400 with digital output

Highlighted
SOLVED
Apprentice

I've had a Samsung Smart TV linked via an optical out cable to a Marantz CR610 hifi system for 4 years and everything worked OK, including Netflix.

 

The old TV gave up the ghost, so in September I bought a new Samsung UE50NU7400 4K TV, connecting it exactly the same way as the old TV.

 

The sound from the TV to the Marantz system works fine, just as before, whether the content comes direct from the TV or from the Sky box which.  The one probem is Netflix.  Netflix works fine through the TV speakers, but if I switch on the Marantz system the Netflix app carries on playing the picture, but no sound comes through the optical out cable to the Marantz system - we just get silence.

 

It appears to be a weird aspect of the Netflix app, but since it worked on the old Samsung TV it seems odd that it's stopped working on the new one.

 

Anyone have any ideas?  Thanks.

133 REPLIES 133
Highlighted

Same problem here. Was working fine a few weeks ago last time I used the Netflix app. Now I can't set the audio output to PCM when watching Netflix. Please let us know when a solution is at hand. 

Highlighted

regarding validating whether it's the app or the firmware. I doubt the App would be allowed to block the settings page. 

Highlighted

Ok,i posted here ages ago so i'll update. It's actually working fine with me now but if i channel hop on Netflix and no sound is played,my soundbar switches itself off 🤔

Highlighted

Same problem here, contacted Samsung and they had me through the on/off, switch cables, stand on your head, sacrifice a 13-yr old virgin etc. Routine then they blamed netflix. Same ***** routine there and they said they have to escalate it to their technical team. Nobody even listened when I said the problem is either tizen or the netflix app is forcing dolby+ and my receiver cant handle it. 

Highlighted

Same problem here on Q70R with a Pioneer receiver. Had this issue before, but was able to change settings from Dolby Digital+ back to Dolby Digital. Now, like everyone else, it is now grayed out. Told the customer service agent this about ten times during our conversation tonight, and a half hour later after changing this and resetting that, nothing is fixed. However, I am glad that I'm not the only one. 

Highlighted

Hello, I have the same problem on QE65Q60RA and Denon receiver, from Polish support get information that Samsung know this issue and they prepare 1359 update that fix this.

Highlighted
Thanks for this update! That is very good news and the first acknowledgement from Samsung that many members posting here have seen/experienced!
Highlighted

Can anyone confirm if the soundbar works with an optical cable and this problem is specific to arc hdmi, before I shell out and buy one?

Highlighted

@Posty_Matt wrote:

Can anyone confirm if the soundbar works with an optical cable and this problem is specific to arc hdmi, before I shell out and buy one?


ARC works for me but not the optical out to my DAC. To use optical you need to set output format to PCM, which you cant do since its greyed out.

Highlighted

Am I right in saying that its not worth getting a dolby atmos soundbar then as the q60 won't play it in true dolby atmos through the hdmi arc or optical cable?

Top Liked Authors