Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Issues with Wi-Fi Connectivity on Samsung Smart TV?

(Topic created on: a month ago)
418 Views
samkim168960
Journeyman
Options

Hello Samsung Community,

I've been having some trouble with the Wi-Fi connectivity on my Samsung Smart TV (model: QLED Q80T). The connection frequently drops, and sometimes it fails to connect to the network altogether.

  • Has anyone else experienced similar Wi-Fi issues with their Samsung Smart TV?
  • What troubleshooting steps can I take to improve the stability of the Wi-Fi connection?
  • Are there any specific settings or firmware updates that could help resolve this problem?

Any help or suggestions would be greatly appreciated. Thank you!

0 Likes

1 Solution


Accepted Solutions
Solution
JAMES4578
Samsung Members Star ★★
Options

Hi @samkim168960 

Do you have the latest firmware which is 2505.4   https://www.samsung.com/uk/support/model/QE55Q80TATXXU/ 

other Ideas include the following:

  switching off Tv for a minute, a soft Reset (pressing and holding  power button on Smart Remote for around 5 seconds until Tv  restarts ) and rebooting router(unplug from mains)  Another possible solution is to change the DNS settings.   Go to  Network-Network Settings-DNS Settings.   Change from Automatic to   to 8.8.8.8 or 8.8.4.4. (Google servers) or 208.67.222.222 or 208.67.220.220 (Open DNS)

Some information here https://thevpn.guru/configure-samsung-smart-tv-dns/ 

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


View solution in context

0 Likes
4 REPLIES 4
Solution
JAMES4578
Samsung Members Star ★★
Options

Hi @samkim168960 

Do you have the latest firmware which is 2505.4   https://www.samsung.com/uk/support/model/QE55Q80TATXXU/ 

other Ideas include the following:

  switching off Tv for a minute, a soft Reset (pressing and holding  power button on Smart Remote for around 5 seconds until Tv  restarts ) and rebooting router(unplug from mains)  Another possible solution is to change the DNS settings.   Go to  Network-Network Settings-DNS Settings.   Change from Automatic to   to 8.8.8.8 or 8.8.4.4. (Google servers) or 208.67.222.222 or 208.67.220.220 (Open DNS)

Some information here https://thevpn.guru/configure-samsung-smart-tv-dns/ 

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


0 Likes
samkim168960
Journeyman
Options

Thank you for you assistance.

 

JAMES4578
Samsung Members Star ★★
Options
Glad the advice proved helpful.

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


0 Likes
samkim168960
Journeyman
Options

thank you once again