Open search

Invalid Mac address


Our TV (UE40J6300) has lost it's wireless connection to our home network. When trying to reconnect it I'm getting the following message: 

"Invalid MAC Address, call Samsung support" 

Have tried the TV reset function but no luck. All our other devices, phones, laptops etc connect without a problem. 

Our TV is only just over a year old. I have seen posts on other forums about this problem with Samsung TV's. 

Any help / suggestions on how this can be fixed without the need for calling out an engineer would be appreciated.


Exactly the same issue but the Reset button is asking for an 4 digit ID password to reset it. 

Do you know what it is?


My tv will no longer connect to WiFi tried support who talked me through steps just to be told I need to pay for engineer to come out, this tv is only 28 month old and was expensive, nothing smart about Samsung right now. 


@Vovo1 wrote:

Exactly the same issue but the Reset button is asking for an 4 digit ID password to reset it. 

Do you know what it is?

Hi @Vovo1,  If you are  sure you have not set up a pin the default one is 0000.   if by any chance pin was changed but has been forgotten there is a guide here


i have the same issue: wifi interface loosing ip and mac adresses after some use. They all show up as "0" in the network status page. Only remedy is to power cycle the tv... i have the latest FW. This is so annoying!


I think it defaults to 0000 (zero zero zero zero)


Most likely you guys are experiencing the same issue as me. Refer to this topic and confirm the behavior: LINK

Please confirm if the issue happens only on WiFi or with cable / ethernet also.

My router uses Cloudflare DNS ( and all other clients work without any issues, except the Q6FN.

Also the router uses the same SSID for 2.4 and 5 GHz antennas, disabling one or the other does not help...

First Poster

This issue is not solved


My model# un75mu6300 

software version#  t-ktmakuc-1262.0,bt-s


It is May 16 2019 and my TV is experiening this problem right now


Please see this screen cap link



the Wireless MAC address section is clearly blank and my TV will not connect to my wireless network. 


I have tried the steps in this post by resetting the TV but the results are the same after a few minutes. 


The TV drops from the wireless and the wireless MAC disappears. 



Samsung please fix this asap. We spent too much money on these TV for this feature not work or break in such a horrible manner like this. A network connection will not work under any circumstance without a MAC address (wired or wireless). 


Finally I solved this bull***** l... had same problem on my qe65q6, it would only connect via ethernet,  when trying to use wifi no networks were found and gave and error about unknown Mac address for the wifi interface.

I tried a factory reset from the service menu, with the only result of remote controller to be unpaired from tv. Press and hold simultaneously RETURN and PLAY/Pause to restore the pairing


Enter the Samsung service menu/option and set connection from "wired" to 'wifi_int,' shut down and restart tv.

WiFi WORKING properly with all. my neighborhood networks showing up including my hotspot connection.


Apparently the 'wired' connection specified in the service menu should be read as "wired only" as we have other modes like 'wifi_int_only' or 'wifi_ext only'. Even the factory reset would not revert the 'wired' mode to wifi_int. 


When wifi is connected if you insert your lan cable back it will prompt you with the question: Do. you want to switch to cable connection? Not sure if answering yes will cause the issue again. In case it does, just re-enter the menu service and change it to wifi_int

If you only use wifi connection, you may just change the value to wifi_int_only


I am having the same ***** issue.  Invalid MAC address        Have tried everything.    Shows my WiFi but has X.  Red X.      Searches for open network and just times out.   *****ing unacceptable Samsung customer service.




Same problem here. Tried everything, factory reset, shutting down for a while, tried to update the firmware but is already up-to-date...


Only thing remaining is try an ethernet connection, but my router is far from the TV. So basically Samsung Smart TV just became Samsung TV. 


Weirdest think is that my guarranty finalised just the day before this problem happened!!! After three years of extended guarranty!! Is this something made on purpose by Samsung?

Top Liked Authors