What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Can you fix your PC HDMI 2.1 handshake issues please!

(Topic created on: 19-12-2020 07:10 PM)

Installing windows 10 with a 55" Q700T 8k TV as a monitor with a RTX 3090 GPU. 


Nvidia drivers updates during installation and at the part where you input your email suddenly sets the default resolution to  720x480 @ 75hz - which even though the screen properties says is compatible, actually gives you a black screen with the top 1/4 screen of distortion.  Can't change the resolution due to not being able to see the ***** image. 


Also , handshake issues. PC comes up as SKY sometimes, TV goes to "no signal present" when selecting 1440p. 8k is a pure jump through hoops to get working and required going into 4k 30, messing about with display settings and hoping that Input Signal Plus works. 


It's a huge mess. Took me 4 hours trying to figure it all out last night, 3x fresh windows installs, lots of hair pulling. I've never had to deal with anything like this before just to choose a native screen resolution. 


For anyone else struggling getting Input Signal Plus working:


Install windows with IS+ turned off so it sees 4k 30hz


Right click desktop "Display Settings"

"Advanced Display Settings"

"Display Adapter Properties for Display 1"

"List all Modes"


Then prey and mess about with it until you get it to 4k 60hz 

Then Nvidia Control panel. 

Mess with settings applying 1 by 1 until you manage 8k resolution with 4:2:0 10bit colour. 


edit: Can't even select 1080p or 1440p any longer with game mode? What's going on, did the last firmware update break it? 







Definitely the latest firmware which is the issue. Managed to mess everything up again and struggle to get it connected back to 8k 60hz as game mode or Input Signal Plus crashed the PC. 


To do it you need a DP1.4 to HDMI adapter. I have one which does 4k 60hz via Display Port. 


Use that from the PC to the TV. Enable game mode/Input signal Plus, then swap the cable from the DP adapter to the GPU HDMI port. Restart the PC and you should start with 4k 60hz game mode enabled. Then just select 4:2:0 10 bit from the GPU control panel, then change the resolution to 8k. To stop the TV from reverting back to crashing each time you load a game with a lower resolution you need to change the GPU settings and set the scaling to GPU rather than the Display. 


Here's the issue if anyone from Samsung wants to actually fix it.

This crashed the PC , when I booted it back again it only booted to 1080p 60hz. Higher resolutions weren't available until I removed the HDMI cable and then it went back to square one with no Input Signal Plus / game mode available.