Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Audio output keeps switching to TV Speakers

(Topic created on: 26-11-2022 05:00 AM)
elFarto
First Poster
Options
TV

I've just bought a UE43AU8000, and I'm having an issue with the audio setup. It's connected to a Sony DAV-DZ260 DVD Home Theater System via HDMI (on the ARC port) and Optical.

The main issue is that when you switch the audio output on the TV from 'TV Speakers' to 'Receiver (HDMI)', it will switch back to 'TV Speakers' in a few seconds. In the few seconds it is outputting to 'Receiver (HDMI)' everything is working perfectly, audio is being outputted over the optical cable, and volume control is going over HDMI. Switching it to 'Optical' output does stick, but obviously I lose volume control.

Now I realise that the receiver is pretty old now, and doesn't support ARC or eARC, but the TV is capable of doing exactly what I want, it just won't stay there.

Does anyone know how to fix this, and get it to stay on the 'Receiver (HDMI)' output setting?

126 REPLIES 126
Pete T
First Poster
Options
TV

Earlier this week my QN85A started doing this and I can’t get it working again.  I have managed to get the audio from my Receiver by plugging it into a non-ARC HDMI port but that means multiple remotes as others have said.  I have not tried plugging all my sources into the TV directly (Firestick and Sky Q) as I like my existing setup.  The firmware is 2101 which was released in September and I assume this is causing the issue.  This firmware seems really interested in the device which is connected to each HDMI and wants to control them.  It feels like Samsung are trying to implement a TV-centric model when I am trying to use it as a panel.  I suspect it might work if I connected everything directly but, as I said, I don’t want that setup.

shaunpc999
Apprentice
Options
TV

I ended up plugging everything in to my AV Receiver and just using the Samsung as a panel. It is useless as a smart TV. You might as well just purchase a very large computer monitor and plug it in. My other TV is a new Sony and has absolutely no issues. Lesson learned - stick with LG or Sony and don't bother with Samsung TV's.

0 Likes
Yeldog
First Poster
Options
TV

Hi, I solved this by using the below settings for my Sonos Beam gen 2 & Apple TV. Might work for other soundbars?

In connections > external device manager:

  • Turn on Anynet+ (HDMI-CEC)
  • Turn off/deselect all HDMI ports In the input Signal Plus menu.
    (Counter intuitive I know…)
  • In Audio > Expert Settings - turn HDMI e-ARC mode to OFF.
  • Set your sound output to your soundbar on you TV settings
  • My Soundbar is connected to HDMI 3 or E-ARC/ARC.
  • on Apple TV set sound output to TV Speaker. (Again counter intuitive - but I guess the Apple TV sees whatever soundbar the TV is outputting to?)

The solution seems to be turning off all HDMI in the input Signal Plus menu.

when I know turn on the TV it can default to the tv speakers for a secs or two but the switches to the soundbar - settings seems to have sorted out any hand shake issues.

 

hope this helps!

CD0CA099-B551-4202-9A5D-D8277CDBA93E.jpeg

 

Pete T
First Poster
Options
TV

Thanks, it seems to have fixed 90% of the problem.  The TV now seems to think it is talking to a Sound System rather than to my Sky Q box which is plugged in the AV Receiver.  I still get an annoying wait of about 5 seconds when I turn the TV on before it switches the Sound System on but I can live with that!  Pity as I actually quite liked the Input Signal Plus feature as it allowed me some control over my Sky Q box using my Samsung remote.

0 Likes
Yeldog
First Poster
Options
TV

No problem.

One other thing I did recently which seems to have 100% sorted it was to set the HDMI e-Arc from Auto to OFF.

I then unplugged my soundbar, plugged it back in and now switches to my soundbar everytime I turn on my Frame TV :smiling-face:

I think my settings my just let the soundbar connect to the TV via e-Arc rather than the TV trying to connect to it? …maybe?

0 Likes
LLenergy
First Poster
Options
TV

I also am using a Soundbar and am having the same issue. Switches from optical to TV speaker intermittently.

0 Likes
Marc Foreman
Apprentice
Options
TV

Hi - I may have a solution for this that'll work for you, but let me give you some context just in case it helps ...

I was originally using an HDR-capable 4K Panasonic TV as a video monitor, connected to my AV amp, and I was not using, nor interested in using, the onboard TV apps or receiving audio from that TV. It was a dumb display device, and I was able to connect to it using SkyQ at UHD 10 bit, Blu Ray also at 10 bit (4:4:4), and my PC, both at 4K 8bit and 10bit.

All devices went straight to the AV amplifier, the HDMI output of which went straight to the Panasonic. I flipped between inputs on the AV amp, and it all worked great.

The Samsung's onboard apps impressed me though, so I upgraded the TV to a 43" QN90B and decided to make use of eARC (on HDMI3 only) so I could play the apps back through my AV amp.

I've found that - counterintuitively - I needed to apply these settings to the TV:

Settings\sound\expert\Sound Output = AV Receiver(HDMI)

Settings\sound\expert\HDMI-eARC Mode = OFF

Connection\External Device Manager\Anynet+(HDMI-CEC) = ON

Input Signal Plus = OFF on all connections (* see note below)

 

THEN I needed to apply the following settings to my AV Amplifier (I use an Onkyo RZ-3100 - difference manufacturers may have their own terms for these items):

Setup\1.Input/Output Assign\1.TV Out / OSD\HDMI OUT = MAIN

Setup\1.Input/Output Assign\2.HDMI Input\[all devices] = HDCP 2.2

Setup\5.Hardware\HDMI\HDMI CEC = ON

Setup\5.Hardware\HDMI\HDMI Standby Through = Auto(Eco)

Setup\5.Hardware\HDMI\Audio Return Channel = Auto

Setup\5.Hardware\HDMI\Auto Lip Sync = ON

 

In this config, I have Sky Q running off the main box at 8 bit (*see note) UHD 4K, and the AV amp automatically changes input to a special TV setting for the eARC channel if I run any TV apps such as Netflix. I then hear the Netflix audio through my amplifier, and not through the TV.

However, upon closing that app and returning to the AV input source, the AV amplifier REMAINS on the TV setting, and although it makes no sense, I hear nothing at that point (possibly because the TV is now configured to receive its audio FROM the amp when its internal apps aren't generating sound).

I manually switch the AV amp back to the desired mode, and everything works as expected.

*Input Signal Plus and 8 bit Video with Sky Q : I've discovered that although Sky Q worked fine in my old setup, the new Samsung connectors on ANY of the HDMI sockets cause the Sky Q box to complain that the socket does not support UHD at 10 bit. I believe this might be due to cabling - I'm using a 7 year old 10m HDMI cable, which doubtless has not only degraded, but also isn't up to the latest specs. Whilst I got away with this on the Panasonic, the Panasonic itself is from a previous generation and I suspect that this is where the link is breaking.

 

So to summarise, as of right now, all works as it should, with the exception of 10 bit HDR.

 

I've ordered a new set of cable interconnects from Amazon, based on fibre optic tech instead of shielded copper. I'll post and let you know what happens.

FYI the cables can be found on Amazon by just searching for "fibre optic HDMI 2.1".

If you DO buy from Amazon, please use "smile.amazon.co.uk" and set up a charity for Amazon to give a percentage of your purchases to - they cover the cost so it makes no difference to your pocket. It's just something that over time can help a lot of people if you use that link as your go-to.

 

Best,

Marc

0 Likes
Marc Foreman
Apprentice
Options
TV

Following on from my previous post ...

Connecting the fibre optic HDMI between AV amp and Samsung HDMI port didn't make any difference.

Connecting Sky Q to HDMI3 directly ALSO didn't help.

However, connecting SkyQ to HDMI2 caused the Samsung to recognise it as, of all things, Apple TV. I could then select it as an input and switch to 10bit HDR without a problem.

This pointed to the AV amp as the issue.

Fortunately, there is a firmware update for the Onkyo which, after applying, enabled HDR to be recognised provided that Input Signal Plus on the Samsung was activated.

And since the eARC also now works flawlessly, allowing me to play the TV's onboard apps sound through my AV amp, I am one happy bunny.

I can definitely recommend the fibre optic HDMI cables though. They didn't change the outcome of the situation, but they are SO much easier to use, with no static charge build up or signal degradation.

Best,

Marc

0 Likes
Stan22
First Poster
Options
TV

Same issue started happening to me without me changing any configs with my Soundbar around October.
I do have automatic updates enabled on my TV so I’m confident one of the latest updates introduced this problem. 

A not so good workaround is to re-connect a soundbar from HDMI3(ARC)  to HDMI1(non-ARC) port.

Koopa210
First Poster
Options
TV

I had this issue with my LG SJ7 sound bar. I had it connected via digital optical but I didn't like having to aim the remote at the sound bar in order to adjust the audio. I connected it via HDMI to use ARC but same thing, after a few seconds it would switch back to TV speakers. Well, I just had to switch the HDMI cable on the sound bar to the output port. It didn't make sense to me since the sound would be coming OUT of the tv and IN to the sound bar but it is labeled ARC on the output port. It's been working fine.