Open search

Apps storage space issue

Helping Hand

TV: UE55 NU7500

I'm not sure whether this is a general Samsung issue or just to do with my TV, but the amount of space allocated to the Smart Hub apps seems to be seriously lacking.


As this is a new TV I thought I'd explore some of the available apps, but when I went into the Apps area I got a message saying that there was insufficient space to update apps. This was before I had downloaded anything, so it would purely apply to the pre-installed apps. 


I checked settings and the used space was 751MB with 64MB available, i.e. 7%. This seems absurd as these apps can't be deleted and are built into the system. The available space doesn't even allow them to be updated. I then tried resetting Smart Hub. This has helped to an extent as the available space is now 13%. However, it's still far too low and whenever I try and download a new app I get a warning about available space.


I can't believe that the pre-installed apps are taking around 700MB of space, and it seems crazy that Samsung would design the system this way. Presumably I will have to install an SD card to provide more space for the apps?

Any tips welcome as this is my first Samsung TV.

1,698 REPLIES 1,698

I've only got 5% free space with only a couple of apps installed now. However I've not had the "unable to update" message when opening the app store for a long time now which is odd. I don't really feel like I can keep on with Currys when the TV isn't displaying any issues.


I have however been having a lot of trouble with the Red Bull TV app, whenever I try to play a video it shows a spinner and after a while it shows a message saying it was unable to play the video. Only after 30-40 odd retries will it sometimes play the video. My laptop in the same locaiton as the TV has no problem playing the same video on the redbull TV website. I don't know if this is a problem with the redbull tv app itself or if it's something to do with the lack of storeage available.


This got me wondering about problems with streaming services and if the lack of available storeage will affect the apps ability to buffer content. With little to no buffer space available it might become problematic or impossible to stream video content.


You make a very good point about the space needed for streaming, not something we've discussed before. I don't think anyone else has reported problems with streaming so far but your issue could be related to the storage issue. Have you tried iPlayer and maybe another free app to see if they stream ok?


I don't think streaming would be an issue as it uses your bandwidth and a tiny amount of diskspace. i've not had any issues with Plex, iplayer etc, dont use redbull tv though, probably an app issue imo.


Just cleared cache from PLEX app and it was 46mb


I got to 240mb+ storage and all default apps removed.


May void warranty I dont know.

disabled TV+ using info settings mute tv/power


Go to Options > MTP Turn tvPlus support off


restart tv go to apps screen

press 12345 and turn developer mode on leave other settings alone.


go to settings menu in apps, go down to deep link scan this enables the delete button. I think people had issues with reinstalling apps as they still had TV+ support enabled.


Turn of auto update and apps auto update to avoid Samsung screwing over its users.




Can you state TV model, because the options are not all the same for all NU models. Whats MTP?? I don't have TV+ support for example. As i said before i have the NU7400, if i goto dev mode the deep link option does nothing.


Also how do you clear cache from the plex app? You mean uninstall/reinstall it or shub reset?


"disabled TV+ using info settings mute tv/power"
how did you do this? could you please post some screenshot? thank you in advance...


by the way i was able to free up 250Mb doing this passages:

1) turn off tvv

2) press the power button ON THE TV (not remote control) for at least 5 seconds

3) press the power button on the remote controll for at least 5 seconds

4) the tv restart doing the first configuration but the memory after it showing 250Mb free

i guess this removes the demo reseller mode



@bIOforger he deleted the Plex cache using his new RU7400 as he mentioned above. It allows you to delete the app cache, which is great. 


Has anyone noticed that the quote option when replying has disappeared? 

oh the RU7400 right, it doesn't really matter with plex, as soon as you start streaming vids that cache will fill up again. Yep, quote has been missing for quite some time, something else Samsung has f'd up
Top Liked Authors