Open search

All 4 app stopped working on Smart TV




All 4 app has stop working via Smart Hub.


The app seems to start but then gets stuck on the loading page


Model Number: UE48H6670.


Any help would be appreciated.

Fuzzy Wuzzy
106 REPLIES 106

I bought a brand new Samsung TV (UE50NU7020) last week and can’t load any 4od programmes at all, same issue. My other Samsung TV would get to the first ad break at least! I have tried resetting the Smart hub but obviously no luck. Almost want to return it but I love everything else about it. Incredibly frustrating.


Spoke to Samsung again today and was basically told that Samsung can't/won't do anything more about it and have passed the buck to All4. They have advise dme to reload their app which I have done so we will see.....! Italso transpires that my TV's firmware was out of date and had not been updated by the autonatic or manual update system.

Shame on you Samsung.! On th ebasis of th equality an dperformance ofmy previous Samsung TV, I bought a new QLED one only to be seriously disapointed not with the TV itself but Samsungs attitide to its customers. All 4 works on my computer but not on the TV so who's fault is it?


i have been having the same problem. samsung conected to my tv looked through it all and at first tried saying it was my internet contection however then said it was not that. they tried doing a update their selfs and said it was not updating to the new update which has just came out. she said can i download it on a pc i said no so they have sent via post a usb stick for the new update. may worth asking for this. will let eceryone know if it works when it comes.


@bsteve wrote:

All 4 works on my computer but not on the TV so who's fault is it?

All4.. it's their app. When I had a problem with it on the Q9FN, I raised it with Channel 4 support, who (eventually) confirmed the issue and a fix came out a couple of weeks later.


Fixed!! I spoke to someone from Channel 4 who advised going on Samsung’s website and manually downloading the firmware. Just put the USB in and it has fixed it straight away.


i just recieved my usb drive from samsung (as i have a macbook, i cant download it) just pluged it in for the update, now my all 4 works!!


Couldn't find anywhere to make new post so used this reply slot to get it on screen.

Having spent hours on the phone to Samsungs unhelpful helpline and also All4 who were blaming each other, I wrote to all of the UK directors of Samsung and emailed the president  - - and am now in touch direct with the presidential escalation team.

I have now got the latest version of the All4 app loaded and, via a usb stick, the latest TV firmmware but am disappointed that it still hasn't  solved the  problem. Samsung's say  that they have had zero reports of the issue persisting  so have assumed that the fault is with my TV and an appointment has been made with their repair team for an Engineer to visit  though what he will be able to do i am not sure. More later.

I am posting this because of the "zero reports". If any of  youout there still have this issue, post it here but more importantly, email the ukpresident and write to the directors individually to let them know.


That is ridiculous that they can even Remotely claim "zero reports" when people have flooded Google and their very own community with reports of the "All 4 apps" not working. This has probably been the most frustrating. The USB download has seemed to be the fix all most consumers have needed, why they can't create a download update that the TV can directly download is beyond me however. Thank you for the post with the Presidential of Samsung information.

I also reset smart hub which then updated the apps. SUCCESS 



Can you provide the contact address for the "escalated" support staff? responds with as an invalid email.

Top Liked Authors