Support

Open search

2020 Q60T QLED TV UK some apps not running video All4 ITV Hub UKTV Play

Highlighted
First Poster

Purchased a Q50Q60T QLED TV only a month ago and three apps, All 4, ITV Hub and UKTV Play don't work properly from day one. They will open ok, select programmes etc but when it comes to playing, just buffer and never load. ITV Hub gives error message after a while. All other apps run fine including BBC iplayer, MY5, Apple TV+, Netflix  etc etc. Samsung initially said its the app providers issue. ITV have investigated and say its not them. Other two not replied.

Spent hours trying all the resets, restores etc etc multiple times plus updated the firmware to latest on website via USB (auto update function doesn't work either!). Internet connection and speed is fine. Other non Samsung TV's in house work fine with these apps.

Getting the feeling its a Samsung issue and still waiting for another tech to call. Anyone else had this issue with these new TV's?? Not good for a brand new out of the box TV advertising these apps work!!

 

2 REPLIES 2
Highlighted
Moderator
Moderator

Hey @GDT38 ,

 

I can see that there is a new update for this TV since September (version 1402.4). Is your TV currently running on this one? To check this head into the TV Settings> Support> About this TV/ Contact Samsung.

Highlighted
First Poster

All updates/resets done. Yesterday, via remote management, after one hour, Samsung tech concluded the TV was faulty. New one on the way from retailer next week - fingers crossed this time

Top Liked Authors