Open search

Samsung s5e wifi issue on Android 10


Ever since the update to Android 10 on July 1st, every time my tablet screen is switched off the wifi will also switch off on the tablet. I've been through all the settings including the developer options and I can't see anyway to stop this. I've reset my settings too, but to no avail. I've had to download an app on the Play Store to keep the wifi on.

Is this a bug or an intended feature of Android 10? And does anyone have any idea how to fix it, other than with a permanently running background app?

123 REPLIES 123

Tried that. It still doesn't connect to wifi after startup until I turn wifi off and on again.



I tried it and it worked but recently when I turned my S5e on, Wi-Fi turned on.

The next time, Wi-Fi didn't connect.

Last week, I turned my S5e on 25 times and on 4 occasions, Wi-Fi connected automatically! I will monitor if this change works! 


Update- switched my S5e off an hour ago and back on just now. Wi-Fi did not connect automatically.  




Thank you for the advice.   I tried the fix but it did not fix the problem.   My S5e still refuses to connect tio WiFi on turn on.   I have to turn the WiFi Off then on as usual.


It is quite clear, that this a failure from Android 10 update. Android 10 for this specific product Samsung Tablet Galaxy 5SE must  receive a fix as soon as possible! To repeat this is a SW bug! A factory reset wilL NOT fix it.

Samsung you need to fix it now with an urgent update!


Sorry, tried your suggestion but no success. Problem continues to exist. It is a SW bug within Android 10 from Samsung. They need to fix it fast.

First Poster

Thanks for all the comments here. I'm a new Android user after having had several iPads ever since iPad 1. I changed in order to have a more open environment. But I didn't expect my wifi to be so unstable with dropouts. This is a disaster, and I regret ever having bought my s5e tablet. If this nonsense isn't fixed very shortly, I'm back on iOS. What a joke this is. Wake up. Samsung!!!!

First Poster

I have facing this same dropout problem. Hope Samsung will fix this as soon as possible...:)

First Poster

I have the S5e Tablet, no problem at the start but now driving me crazy, wifi dropping out constantly.

I swipe down the screen and manually switch off wifi and then on again, that works eventually till the next time.

I have factory reset the Tablet and trouble shooted everything I can but why do we have to put up with all this hassle when Samsung knew full well about the wifi issue long before we even bought ours.

The retailer doesn't want to know you or even see the evidence I have collected by videotaping the problem on several occasions on my phone.

They believe me, a lot of good that does.

We have bought over a dozen Samsung items for our family over the years.

Samsung where is your loyalty? Just do the right thing and give us our money back.

This Tablet is not fit for purpose only fit to drive us crazy!  I would not have bought it had I known about the wifi issues.

This is a major design flaw by Samsung, deserving of setting straight.

I'll happily buy a different Samsung Tablet as long as it doesn't have this wifi issue.

You knew long before I even bought my Tablet.

Hopefully, the Dept of Fair trading will help me out, at least they are on the Consumer's side!


I think I found what the solution is. Apparently, it has something to with the Setting named Lock Screen. Open it and touch Smart Lock, enter your PIN (I do not use other ways) which opens Smart Lock and touch Trusted Places. My Home address is there as "From Google Maps". Touch it and at the lower end, one sees a line that says Turn on this location. Turn it on! That should resolve the issue. I did a cold start and a restart, and the WiFi connected automatically.


Nice theory, but unfortunately my home is already turned on as a trusted place and I still need to switch wifi off and on again every time I turn on my tablet before it starts working.

Top Liked Authors