Support

Open search

Samsung s5e wifi issue on Android 10

Highlighted
SOLVED
Apprentice

Ever since the update to Android 10 on July 1st, every time my tablet screen is switched off the wifi will also switch off on the tablet. I've been through all the settings including the developer options and I can't see anyway to stop this. I've reset my settings too, but to no avail. I've had to download an app on the Play Store to keep the wifi on.

 
Is this a bug or an intended feature of Android 10? And does anyone have any idea how to fix it, other than with a permanently running background app?

123 REPLIES 123
Highlighted

I can see two choices when I switch the WiFi on and understand that they are 2.4ghz and 5ghz. My understanding stops there! Is that telling me that my WiFi is split? Can I test anything else?

 

Ofiaich. 

Highlighted

You would have to give the 2.4ghz and 5ghz SSID's different names to split them, if you haven't already done so. You can do this in your router settings on your web browser.

 

You would then need to reconnect any devices you have connected to your router.

Highlighted

My SSID have different names,  for example,   SSID and SSID_5G .

 

I switched my S5e on just now and it picked up SSID automatically! 

 

Ofiaich 

Highlighted

My 2.4ghz & 5ghz are split under different names but I still frequently get no wifi on powering up S5e. None of neighbours wifi's show up either until on/off toggled. Even when working S5e only shows about half of neighbouring networks to those shown by my old Tab S 10.5 .As mentioned in my earlier post wifi signal strength reception much weaker  on S5e than Tab S.

Highlighted
Explorer

Found this, 

"If you hold the specific area where the Wi-Fi antenna is located, the Wi-Fi communication performance could be affected.  This is similar to other products and devices that support Wi-Fi communication. If the Wi-Fi signal is strong, holding the antenna part does not significantly affect the performance.  But a weaker signal, from a router that is far away (or on another floor), covering part of the antenna may affect the signal performance, and it can result in a loss of Wi-Fi communication.  In this case, if the router supports both 2.4 and 5 GHz, we'd recommend making both networks discoverable, and connect to each one of them, saving the password and choosing the ‘Auto Reconnect’ option in Wi-Fi settings of the tablet. Alternatively, you can try the steps listed here:"

 

 http://stgwebus.samsung.com/us/support/troubleshooting/TSG01001559/

 

Seems these WiFi problems are very common.

 

Ofiaich 

Highlighted
Explorer

Engineer called today. Took the tablet away to his techno_vandroid_10.

 

He said he checked everything even my installed apps to check for conflicts but could find none. His conclusion was the issue is Android 10 issue and Samsung is usually good at releasing patches.

 

I did search more and found the US Samsung Community,  XDA and other sites have reported on this issue.

 

Ofiaich 

Highlighted
Thx Ofiaich. You've done a great job researching this issue. Let's hope Samsung's fix isn't too far away.
Highlighted

Hi! I have exactly the same problem, and it is very annoying! Have you found a solution?

Highlighted
You've come in on the earlier part of this thread. Search for posts by Ofiaich and in particular, his post of 3rd August, which should put you in the picture. Basically, we await a further fix from Samsung.
Highlighted

Thanks @PedroUK!
You are correct! Meanwhile I had an online chat with Samsung support, and while going through the usual (unhelpful) moves, I noticed something else - every time I start the tablet in Safe Mode, it starts with Flight Mode enabled.

I mean - every single time in Safe Mode - it starts in Flight mode, which we know turns off all radios by default.
After restarting back in normal mode - the usual - WiFi icon is lit, but there is no connection and no networks in the SSID list. I need to toggle the WiFi connectivity manually to get connected. this behavior is persistent on my tablet.
For my part, I am convinced that there is a BUG in Samsung's firmware, related to Flight mode being enabled by default in the background, after a restart.

Obviously, as you already pointed it out - Samsung must fix this!

 

Top Liked Authors