Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Watch 6 and note 8

(Topic created on: 07-09-2023 01:16 AM)
2026 Views
John177
First Poster
Options

I cannot register my watch 6 on my note 8.

The note 8 has android 9. Is it too old?

Must I root my phone to a newer version of android?

0 Likes
6 REPLIES 6
Daniel-M
Moderator
Moderator
Options

Hi!

You need to have a phone running Android 10 or newer to be able to connect the watch.

/Daniel
0 Likes
PD_G
First Poster
Options

I have the same problem with my A5 (2017).
It's running on Android 8. According to the page, Watch 6 works with Android 5+...
A new phone is on the way ... still.

It should be possible to make a watch configuration without an app. Especially if the shop is stating false information.

0 Likes
Daniel-M
Moderator
Moderator
Options

Hi!

Could you link to the page where you found it said it supports Android 5+? Only managed to find that it supports Android 10+.

/Daniel
0 Likes
JakeSully
Samsung Members Star ★
Options
Galaxy watch 3 and down are compatible with android 5+ but galaxy watch 4 needs android 6+ and galaxy watch 5 needs android 8+ and galaxy watch 6 probably needs android 10+ or higher.
0 Likes
Zall3
Apprentice
Options
I have s21 with android 13 and one ui 5.1. Same connection issue as above.
0 Likes
Emmi S
Community Manager
Options

Hi @Zall3 

You should not have issues since you have android 13, please contact our support for troubleshooting!

/Emmi
0 Likes