Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to give prio to wifi over 5G?

(Topic created on: 14-04-2023 08:17 PM)
597 Views
PatrikT
Explorer
Options

I have an Galaxy S21 5g and right now 5G network is beeing rolled out where I live. So far so good. 

But I live on the border of 5G coverage so 5G coverage comes and goes, depending on network load so phone switches between home wifi and 5G - which is NOT good when in the middle of a teams meeting - then I get paused /both muted and loos audio) for approx 5-10 sec while phone is switching from wifi to 5G or vice versa.

I want phone to be on wifi as long as coverage is decent and only switch to 5G when I completely loose wifi = when I actually leave home. I do NOT want to set network manually. It worked perfectly fine when I had 4G coverage only. Then I used wifi when at home and when leaving home I got handed over to 4G but never switched from wifi to 4G when stationary at home within wifi coverage.

I guess phone picks fastest connection and 5G is probably faster than wifi and therefore phone switches but still I want to enforce "use wifi when available and only switch to 5g when wifi fully unavailable", or in other words

Prio1: Wifi

Prio2: 5G

Prio3: 4G

I have tried a lot o network settings but phone still keeps switching, resulting in breaks in teams meetings.

Home wifi is table, fiber2home and then provided by an ASUS AT68 router, very stable on for example laptop and also before 5G rollout started in my home area. No breaks in teams meetings before 5G rollout started.

I want to stay on wifi to avoid the breakings, so is there any setting I can do to achieve this?

Thanks in advance!

/Patrik

 

 

9 REPLIES 9
JakeSully
Helping Hand
Options
Reason why it switches is possible that your phone detects your WiFi is weak so it temporarily switches to 5G. Make sure your WiFi is good to make it stay on WiFi. Other alternative is to disable auto switch between WiFi and mobile broadband in your phone settings so it stops switching.
PatrikT
Explorer
Options
Disable sutoswitch is not an option, when I actually leave home and home wifi, then I really want the autoswitch.
0 Likes
JakeSully
Helping Hand
Options
No not that auto switch, there is 2nd one that switches when WiFi is poor then it goes to 5G instead. Disable that one so it stays on wifi. Open wifi settings --> pick Inteligent WiFi and then disable change to mobile data. That feature switches between WiFi and mobile data when wifi is unstable or slow.
0 Likes
PatrikT
Explorer
Options
Thst setting is Already off
0 Likes
JakeSully
Helping Hand
Options
Then there must be an issue with your router since it drops from WiFi and goes to 5G.
0 Likes
PatrikT
Explorer
Options
I would not think so, my laptop gets stable wifi connection, NO interruptions in teams meetings when connecting via laptop
0 Likes
PatrikT
Explorer
Options
Laptop has wifi only, and NO mobile connection
0 Likes
JakeSully
Helping Hand
Options
Laptop has better antenna than phone does. It can also be due to your routers channel. But I still think issue is your router
0 Likes
PatrikT
Explorer
Options
But then why did it not happen before 5g was introduced? I never noticed the same with 4g.
0 Likes