What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

QN90A + 7900XT HDR FreeSync Problems

(Topic created on: 16-01-2023 02:31 PM)
First Poster

Hello, for a whole week i am trying to fix mentioned problem,

I have 2.1 HDMI (48Gbps ) certified cable. 4k 120Hz HDR gaming worked flawlessly for last 6 months on Nvidia GPU.

When i have TV set to game mode, windows hdr on - signal is only free sync premium pro and my tv picture gamma is locked at 2.2 or 1886  ( which means it is not in HDR), after a lot of testing, i still can not fix it.

When i have game mode off on tv, i can easily enable HDR in windows and TV recognises HDR as well as 120Hz. On picture gamma i have automatically set to ST.2084.

When i turn back game mode on, my picture gamma goes to 2.2 , i lose all colours, brightness.

I cannot have enabled both Free Sync and HDR at once.

I have tried 6950 XT and 6800 XT gpus also and same problem persists.


After looking for solutions i found some people had luck with CRU, i did everything as instructed but when going to game mode i still cannot get HDR.


Only thing it says is " Free sync premium pro" which should have HDR inside, but difference between playing like this or without game mode is night and day. Screen becomes 3 times brighter than in game mode, but then i have a lot of screen tearing.

Any suggestion would be helpful.



I have the same issue on my QN90A using a 6900XT. I have managed to get HDR in ST2084 with Freesync Premium engaged in 120HZ but either AMD driver is messed up or QN90A EDID is messed up, because Freesync Premium Pro is causing the TV gamma to lock at 2.2, not ST2084, causing the dim picture. NVidia 3080 I had previously used VRR and HDR perfectly. If only we could exchange freesync for hdmi forum vrr... Anyways do this to get brighter HDR...

In CRU folder, run reset all and then restart 64 so we are starting fresh.

Make sure tv input signal plus is enabled for hdmi port 4, which we will be using as this is the only port with hdmi 2.1 support. In TV menu it is settings>general>external device manager>input signal plus

In windows, make sure your TV is in PC or Console mode as the source. Switch game mode off. Enable 4K and HDR and set to 120HZ in windows display settings.

In AMD driver, set 10-bit color depth Full RGB 4:4:4 or YcBcR 4:4:4 in display settings.

In AMD driver, set 10-bit pixel format off in graphics settings.

Open CRU and click on the extension block listing at bottom so it is highlighted blue and then click the edit button below.

Highlight TV resolutions and click edit. Delete the 24/25/30hz options here to free up space in the extension block and click ok.

Now, click add, and select freesync range from the menu. Put 48-120Hz. Click ok. Click ok again and you should be back to the cru main page. Click export and save your file as any name you want but leave format as .bin file

Now, close cru and put tv back to game mode and make sure you enable 120hz, 4k, hdr and full rgb 4:4:4 or ycbcr 4:4:4. It should be on freesync premium pro and looking dim as it was before. Open cru again. Click on import and pick the file you just saved. Click ok to exit cru. Now run restart64.exe in cru folder. Your display should now be detected again in freesync premium (not pro), which seperates the hdr from freesync, with the tv doing the processing using the st2084 gamma curve, resulting in a much brighter picture and better hdr all around.

There is still an issue where switching between hdr on/off or changing resolution or refresh rate can cause signal loss. I have found that if I keep moving my mouse whilst making these changes, the signal is never lost. If you do lose signal, switch to another hdmi port and back again using tv remote. If still not detected, push ctrl, alt and delete together and try again as the screen which pops up by pushing these buttons is consistently detected for some reason...

I hope this helps you and others, please do not hesitate to reply and ask anything if you encounter any problems :smiling-face:



Hey this is OP of post, i am on other account as i do not remember the right email at the moment.


Thank you for sending such a detailed guide, I have before tried using cru and failed, but since you have explained so good i decided to try steps above. After switching to Game mode, and checking that all settings are same as without gamemode, I have used CRU to import settings as mentioned. 

Sadly problem persists, I still have free sync premium pro when checking signals. I have tried both 3840x2160 and 4096x2160 resolutions.


After long time with customer support of samsung ( my country) and countless word documents sent of what i've done to check the problem, they only answered that this is "AMD" problem even though hdr is working without a problem when playing without gamemode.


I hope future patches will fix this because it's annoying. Since i bought this TV in august i can still return it because it doesnt work properly.

I have tried a lot of stuff like:
-checked all driver updates ( like socket etc),
-trying other amd GPUs,
-Changing cable ( using DP - problem persists).
-trying PS5 ( hdr works perfectly),
-updated from windows 10 to 11
- tried to DDU,
-tried turning on hdr without having drivers installed,
-checked TV firmware for updates.

Sadly a lot of people had problem solved using CRU but i can't seem to get it to work, I have also tried reverse method to get free sync to work without gamemode ON, but even this cannot be done...

Thank you again for taking your time to help me.
Best regards