Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

WhatsApp incoming call - screens remains off on Samsung A50

(Topic created on: 26-03-2019 05:36 PM)
17959 Views
Rj_Sunny
Apprentice
Options

When my phone is locked and screen is off and I receive a call on WhatsApp, it rings but the screen remains off. How can I make WhatsApp turn on the screen to show the incoming call screen ?

Phone: Samsung GalaxyA50 - SM-A505F/DS
Android: 9
WhatsApp Version 2.19.69

Always On Display is enabled. Disabling it makes no difference.
I have tested the behaviour with Skype, Facebook - these apps DO turn screen on for incoming call.

10 REPLIES 10
Zizoukab
Student
Options
Exact same problem here, and it is annoying
0 Likes
Rj_Sunny
Apprentice
Options

Still no solution from anyone... 😞

0 Likes
AndrewL
Moderator
Moderator
Options
@Rj_Sunny: Sorry to hear that you're having this issue. To troubleshoot the situation please go to Settings > Apps > Whatsapp > Battery > Allow Background Activity > Back > Notifications > Allow.
0 Likes
Zizoukab
Student
Options

Doesn't work as well.

Thanks for the help but i guess it's an issue with android pie and with whatsapp

Rj_Sunny
Apprentice
Options
Already done, No vein.. 😞
0 Likes
Ti42
First Poster
Options
Hold down whatsapp icon
Select App info
Select Battery
Select Allow background activity
0 Likes
Star11
First Poster
Options

Thanks Andrew. I would also like to add. Turning off "Put app to sleep" worked on my S9. Settings -> Device Care -> Battery> WhatsApp -> Turn off Put app to sleep.

 

Thanks!

0 Likes
hafiz2
First Poster
Options

tq alot it work 100% on my samsung a70....tq for sharing the way to solve it...very annoy when it happen tq again....

0 Likes
zohrah1
First Poster
Options

i have the same problem with my s7 edge. how can i solve this 

0 Likes