Support

Open search

turn off Two-Step Verification

Highlighted
First Poster

Hi,

few days ago I changed password for my second account on SG9. After change, system want from me in 2nd step  code which was generated in procedure of creation account. Not code form SMS or email - I have access to phone and email. I dont remeber codes because I created account many years ago, when I use SG2. An now, after few years, I cant log in to my account because of codes. How can I turn off Two-Step Verification withot logging to account ? Is there special support addres where can I send ask for turn off 2 step verification ? Really only one way is factory reset phone and creating new account ? Especially when I have access to emial and phone (SMS). Why Two-Step Verification ask me for code form list and not from SMS or email ?

110 REPLIES 110
Highlighted

I have a problem with 2 step verification. When I get the SMS vith the code, the window with 2 step verification is poped back on and I can enter that code as many times I want, I can not verify my device.

Highlighted

This is the same problem we all have. Samsung doesn't care. Vote with your money and don't buy their products again. 

Highlighted

Are you sure it's 2 step verification as there is device verification as well

 

2fa is when you login on any device or computer via a browser and it automatically sends you a sms code to your main phone account mobile number without asking (that system should be functioning fine, do make sure you have updated your phone to currant version as I found out of data s9 wound not login when it was out of date) 

 

If your manually entering the mobile number when your logging into your Samsung mobile phone account on your device that is not 2fa that is device verification (you can't turn that off) make sure your only entering the mobile number without the County code, if thst does not work add the country,, repetitive enter of the failed verification code won't make it work it just get you locked out for 6 hours I think

 

So if you are manually entering the mobile number (or auto fill incorrect auto filling it, as where I found it was not working originally) if your mobile number is like this +44 6666 55544 you need to change it to your local number without the country code witch be 06666 555444 for example

 

If you don't need samsung services don't sign into samsung account on your Samsung phone 

Highlighted

This issue with the looping on two step verification setup is being raised in at least two other threads. Samsung doesn't care !
See
https://eu.community.samsung.com/t5/Other-Smartphones/Trapped-Two-Step-Verification/m-p/1708347 
and 
https://eu.community.samsung.com/t5/Other-Smartphones/turn-off-Two-Step-Verification/m-p/1723954 

Highlighted

@  everyone is receiving the text message with the 6-digit two-step verification code, but when you enter the code it just loops back to the same screen requesting the code. Even if you request a new code the same thing repeats. 

 
Highlighted

Yup, that is the problem.

But the main problem for me is that I can not restore my phone after reset...

Highlighted

@Baysider wrote:

@  everyone is receiving the text message with the 6-digit two-step verification code, but when you enter the code it just loops back to the same screen requesting the code. Even if you request a new code the same thing repeats. 

 

This is Not 2FA ,, its device verification as I had the same problem (your on the black screen on your phone) you must remove or add the County code (uk it's +44 or 0044 do not enter the county code into the box when it asks for the number or it will send you an invalid device verification code 

It is valid, just loops...can not finnish verifying
Highlighted

@leexgx  the number in my account is recorded in that format (+61 ....). There actually isn't any choice because the first line requires you to select your country code from the drop down list. Then on the next line you have to enter only your local number.

I tried entering the number in the second line with and without the country code in front. Either way I receive the SMS with the code, but the page still loops no matter which way the number is entered.

Highlighted

@Baysider wrote:

@leexgx  the number in my account is recorded in that format (+61 ....). There actually isn't any choice because the first line requires you to select your country code from the drop down list. Then on the next line you have to enter only your local number.


yes so on the Dropdown box you pick the +61

the phone number box below only enter your mobile number (begins with a 0) so if its +61 2222 333 444 you just enter 02222 333 444

 

if that fails put the +61 2222 333 444

 

the problem is samsung is using the mobile number as the Seed for the code that phone is expecting but there sms server is auto correcting whatever misakes is in the number and then using that to make the code witch wont work as the device is expecting the number that you entered on your phone

 

the annoying thing is it does not matter if you have 2FA enabled on your account your Phone wont use it it wants the device verfication (just checking now on my S8 to make sure i am correct)

 

i mean i could even generate a code just for you if you used my number and it problery work (but i recommend doing that with a Uk person you know, you just enter there number and it send them your code and then you enter it)

Top Liked Authors