Open search

Sim network pin blocked. Enter sim network PUK S7 And S8. HELP (Phone at fault not the simcard)



We have run into a huge problem with 2 phones one's a S7 and the other is a S8. We switched from Vodafone to Three UK, Vodafone gave us the NUC Codes to unlock our phones.

Now here's the problem when ever we put the sim card in the S7 Or this S8 its constantly asking for a PUK Code. from what i could tell is that a PUK Code is needed when the simcard has been blocked but we know that the simcard has not been blocked as we tried it it another S8 that is fully unlocked and the simcard is confirmed to be working. Even another simcard that we know is 100% Working once we put it into this S7 or the other S8 instead of asking us for a NUC Code it constantly asks us for a PUK Code even though the simcard has not been locked.

Three support have tried helping but constantly just give out the same PUK Codes to me even though we know the phone is at fault.


I am at my witts end with this. This is my sons S7 And my Wifes S8, My S8 unlocked flawless and asked for the NUC Code when i put my new three sim in the phone.

Superuser I
Superuser I

Did they have their Sim card Lock on in their phone settings @Karl20092? Because if they had it'll be the Vodafone sim it'll be locked on and you might need the PUK codes from Vodafone to remove the Sim Lock from their phones, so ask Vodafone for PUK codes for each phone and enter the PUK code and see if that then allows the NUC to be entered. 


Nah no sim lock, This is pretty much a case of needing the MCK Code from samsung/vodafone..

quite a few others have had this issue and found lots of forum threads on vodafone.


Ah after reading those threads @Karl20092 it seems you're requiring the 

DEFREEZE/MCK/Master reset code', and enter that before entering the NUC, and it seems you'll have to get the team to understand what's happening in the first instance, typical Vodafone, the team required is the NUC resolution team at Vodafone, what a mess. Let us know how you get on buddy.


yeah, Figured that out and shot off a email to nuc resoulations. just waiting on a email back from them. I of course have linked them in on everything and posted all the forum posts. So that they can get it into their heads what the issue is and that i need a MCK Not a PUK lol.


It just seems that Samsung makes this harder but locking the phones then calling it a PUK when it's locked which isn't the case so that throws everyone off and sends you around in circles. I am hoping they can help as i spoke to a mobile repair shop i use often in town and they would charge me £30 to get the MCK codes. Of course if i can avoid having to pay £60 for two phones then ill try my best


Yes a few people mention that in the threads @Karl20092 that Samsung's wording could've been better because that's where the confusion stems from.


It's weird that your phone unlocked no problem and the other 2 are coming up with that message, in one of the threads they mention taking the sim out and starting the phone without the sim and then enter the NUC, did you do that and the other 2 phones had their sims still inserted? I hope you get this resolved quickly, and hold off on that £60 buddy and get Vodafone to do it for free!


I used UnlockPlus to unlock mine. Service was fast, price was good, 20. And it saved me from the nightmare of going to my carrier that was finding all kind of excuses to delay having my phones unlock. Using UnlockPlus worth every penny.

Read this helpful article:

Hi all

Just a reminder to exercise caution when using unofficial services or apps, especially those with related charges.
hey hi John,

I have a similar problem wherein my Samsung S8 doesnt work and gives "sim network pin blocked enter sim network puk" prompt after entering sim card. I bought this phone last year from india nad used it for almost 3 months before coming to indonesia. when i try to use an indonesian sim card... it asks for PUK.... which i confirmed with the service provider, is a mobile phone issue. FYI..the same sim card works in other phones seamlessly.

please help. The phone is lying idle since a long time. Paid almost $980 back in june17 for this phone.

Hiya, i am at my wits end as the NUC is not working on the S7. Did you have difficulty with yours. When I press the unlock button to put in the pin there are only 4 spaces and yet the pin is 8 digits. I have re-requested the NUC and got same pin back. Help please.

Top Liked Authors