Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S8+

(Topic created on: 03-07-2018 08:32 AM)
Claired28
First Poster
Options
Other Smartphones

Good morning, why does my 4g/H symbol keep coming on and off when using wifi?

0 Likes

2 Solutions


Accepted Solutions
Solution
John4Oh
Superuser I
Superuser I
Options
Other Smartphones

It'll happen when your Wi-Fi drops signal @Claired28 and it'll automatically switch to mobile data, if it's switched on. If you don't want it happening then simply switch off your mobile data when using Wi-Fi. 

View solution in context

Solution
BandOfBrothers
Superuser II
Superuser II
Options
Other Smartphones

Hi @Claired28

 

You can change the set to us on your Samsung Galaxy s8+ so it does not try to change connection. 

 

Pull down your notification shade and long press on the Wi-Fi symbol. 

Choose advanced. 

Turn off 'Switch to Mobile Data

 

 


Current Phone >Samsung Z Fold³ 5G.

Previous Phone > Note 20 Ultra 5G SM-N9860.

View solution in context

0 Likes
6 REPLIES 6
Solution
John4Oh
Superuser I
Superuser I
Options
Other Smartphones

It'll happen when your Wi-Fi drops signal @Claired28 and it'll automatically switch to mobile data, if it's switched on. If you don't want it happening then simply switch off your mobile data when using Wi-Fi. 

View solution in context

AndrewL
Moderator
Moderator
Options
Other Smartphones
Hi @Claired28

It sounds like Smart Network Switch may be enabled, in which case you can disable this option by going to Settings > Connections > WiFi > Advanced > Smart Network Switch > Off. As advised by @John4Oh, you should also ensure that Mobile Data is disabled when connected to WiFi to prevent any unwanted connections.
0 Likes
Claired28
First Poster
Options
Other Smartphones
Thank you
0 Likes
Claired28
First Poster
Options
Other Smartphones
Thank you, can't find smart network switch though but it's ok I'll turn mobile data off when at home. Thanks again for your help
0 Likes
Solution
BandOfBrothers
Superuser II
Superuser II
Options
Other Smartphones

Hi @Claired28

 

You can change the set to us on your Samsung Galaxy s8+ so it does not try to change connection. 

 

Pull down your notification shade and long press on the Wi-Fi symbol. 

Choose advanced. 

Turn off 'Switch to Mobile Data

 

 


Current Phone >Samsung Z Fold³ 5G.

Previous Phone > Note 20 Ultra 5G SM-N9860.

View solution in context

0 Likes
Macblank
Explorer
Options
Other Smartphones
Easy, when using WiFi, you're NOT using 4g/H, so the symbol drops.

When you're NOT using WiFi, or have a poor WiFi, 4g/H pops back because you're now using data.

There's nothing wrong, it's standard. If you've got it set to WiFi/boost, then you'll probably see 4g as now you're using BOTH.
0 Likes