Open search

S8 smart lock - trusted location issue




the smart lock - trusted location option is not working as it should do.

i've set up my home address as a trusted location, however, my S8 device is unlocked everywhere.

just realised this while i was in the office, that i can access my device withouth using the PIN or the fingerprint.

i've oppend the maps and the location that it shows up is correct. 2miles away from my home address.


the only workaround that i found was to turn off the trusted location, and now the device is asking for the PIN.


this is a serious security issue. the trusted location option is not that trusted :smiling-face:


any idea?




116 REPLIES 116

If you follow my instructions you will get it to work quite well. Read them carefully. Everytime I arrived home from work it works almost 100%. Sometimes I have to restart my phone if it has Lost the connection to the server. 

I usually have to restart my phone next morning which is of course over 4 hours from the last use of the phone. Clearing the Google Maps cache helps If phone doesn't recognize the location properly and sometimes after a major system update it might not work at all, then only Google Maps cache must be cleared nothing else helps. I suggest you to start troubleshooting by checking out your phone location by Google Maps and then add a couple of locations most often found to your Trusted locations.

Thanks. Your assessment sounds like what I've also been experiencing.


It happened this AM. I'd left phone on charger overnite. B4 putting it on charge, SmartLock was working. This AM it failed. Restarted phone & it seems to be working. Will see how it goes today.

For me this happens all the time. If I Stay at home for a long time it seems to fail to understand that I am still at home. Whenever I come to home from work, it understand that I have just come to Trusted environment. Also I have noticed that when I go away from home first time when I open the phone with things that I'm still at home and opens the phone right away and only after that it starts to require PIN code.

One big problem though is that this didn't happen a few months ago, it happened right after an update, went months with the smart lock working, got an update, no more smart lock


Did you try that clearing the Google Maps cache and then restarting the phone? In one if the cases I have seen, that was the only thing that actually helped. 

After clearing the Google Maps cache, deleting the old trusted places and adding them again might also be a good idea. I somehow can't imagine that those who did the update would actually test the functionality of all features.


Yes, cleared cache, cleared data, cleared dalvik, erased smart locations, put them back, used home, used coords for home, set home location then 8 more around the house overlapping home location (N, NE, E, SE, S, SW, W, NW), force stopped maps, used GPS keeper which worked for a week, set the home location in samsung account, turned off battery optimization for location services and maps and basically anything I could find that said location, turned off app power monitor, I've done a factory reset, and I'm sure someone will ask so yes my high accuracy mode is on with the wifi bluetooth scanning


Edit: I've also tried other 3rd party apps to fix gps, and registered my location with 911 services just in case that location was needed, highly doubt that though, not sure about other providers but for the sprint calling plus you have to, which coincidentally the wifi calling rarely works either, nor does SMS/mms work properly


Heck, I have my Smart Lock set to trust when it's connected to my smartwatch, but that doesn't work either, even though I always have the two devices near one another.  It still asks me to PIN unlock (no fingerprint scan allowed) at seemingly random intervals.  


I've tried setting it up so that I have overlapping trusted locations and overlapping trusted bluetooth devices and on-body detection.  Then, I've tried it with everything deleted but the watch.  It still locks the phone at times it shouldn't.


How is it hard for them to get this to work?  If my trusted watch is paired, unlock the phone.  If micro dropouts in the connection are triggering a re-lock, create a threshold before the connection drop triggers the lock.  It's not that dang hard.


Luckily my device lock works with my watch but if I'm at work id rather not have that enabled, if I'm not near my phone but within blue tooth range its not secure


Also since this thread was marked as solved and its quite obviously not I started a new thread

Top Liked Authors